  シーエスヘルプ

  シーエス作成コンポーネント　Copyright(C)シーエス


はじめに

シーエス

シーエス社内コンポーネントを使っていただきありがとうございます。

このコンポーネント群の基本設計はなるべく、Delphi標準のコンポーネントで
プログラムを作成し、できない部分またはめんどくさい部分をコンポーネントとして
提供しようとかんがえられたものです。

ですから、標準コンポーネントから継承されたものが多く、それゆえにあらゆる部分に
制限がありますことご了承ください。

コンポーネント群

TScrollBoxEx

TMCCBoxEx

TNumEdit

TKanaEdit

TTextMarge

TEditGrid

TCalButton

TCSPrint


  その他

  シーエス作成コンポーネント　Copyright(C)シーエス


  TCBColumn

  シーエス作成コンポーネント　Copyright(C)シーエス


制限事項

  TScrollBoxExの制限事項

  １．単体で実行する場合ば良いのですが、FormCloseのみで
  破棄されず、ふたたび、FormShowされる場合はかならず
  Closeされる前にItemIndexを戻しておくか、再度のFormShow時に
  初期ロード位置(Top)に戻る仕組みが必要です。
  これはDELPHIの制限でTop,Leftは１６ビットIntegerであらわされるからです。

  ２．TScrollBoxから継承したプロパティで変更すると動作不安定になる可能性があるもの
  Align 表示がおかしくなる？？？
  AutoScroll 機能を使えない
  VertScrollBar ItemMaxとItemHeightを変更するとVertScrollBar.Rangeが変わる。（逆では変わらない）
                                  但し、縦方向のスクロールバーが必要ない場合はVisibledプロパティをFalseにしてもよい。
  HorzScrollBar 一応使えるが使用しないほうが見栄えする。


   継承

        |

  TCBColumn


プロパティ

  リファレンス
  TCBColumn プロパティ
  TCBColumn

  TCBColumn

    Alignment

    Color

    Font

    ParentColor

    PatrntFont

    TagString

    Width


メソッド

  リファレンス
  TCBColumn メソッド
  TCBColumn

  TCBColumn

    Assign

    Create

    Destroy


イベント

  リファレンス
  TCBColumn イベント
  TCBColumn


 例

MCCBoxEx1.Columns[0].Color=clLime
MCCBoxEx1.Columns[0].Width=100
MCCBoxEx1.Columns[1].Color=clAqua
MCCBoxEx1.Columns[1].Width=200

注意　ドロップダウンリストに出現するスクロールバーは右端に勝手に付いてしまうのでその分
        余分に幅を取ってください。
        ドロップダウンリストはフォームの端やスクリーンの端に関係なく表示されてしまうので
        設計時には，そのことを考慮にいれたうえで配置してください。


  TCSPrint

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TCSPrint


プロパティ

  リファレンス
  TCSPrint プロパティ
  TCSPrint

  TCSPrint

    BackBmp

    BackColor

    BackColorS

    Copies

    DDataSet

    Direct

    FontN

    FontS

    FontSH

    FormName

    HDataSet

    LeftMargin

    MaxColumn

    MaxLine

    PageEtype

    PageNo

    PaintColor

    PaintColorS

    PaperMode

    PaperTray

    PColor

    PDuplex

    PName

    POri

    PQuality

    PResolvX

    PResolvY

    Preview

    PSize

    PSizeX

    PSizeY

    RightTrim

    ScrMax

    ShowDialog

    Title

    TopMargin

  TComponent からの継承


メソッド

  リファレンス
  TCSPrint メソッド
  TCSPrint

  TCSPrint

    Create

    Destroy

    PrintInit

    Abort

    BackPaint

    BeginDoc

    DetailPrint

    DetailPrintO

    EndDoc

    HeaderPrint

    HeaderPrintO

    Level2Print

    LinePrint

    NewPage;

    PrintBitmap

    PrintBitmap2

    PrintBox

    PrintL

    PrintLine

    PrintP

    PrintPageText

    PrintTerm

    PrintText

    Reprint

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TCSPrint イベント
  TCSPrint

  TCSPrint

    OnDAction

    OnHAction


Prn_Line_Inf型

  リファレンス
  Prn_Line_Inf 型
  TCSPrint

  Prn_Line_Inf型は,罫線印字情報を指定します。

  type
    Prn_Line_Inf = record
      StGyo : Currency;　　開始行(行の下)
      StRetu : Currency;　　開始列(列の左)
      StP : Integer;　　開始位置指定
      EndGyo : Currency;　　終了行(行の下) U 2001/02/24
      EndRetu : Currency;　　終了列(列の右) U 2001/02/24
      EndP : Integer;　　終了位置指定
      Point : Integer;　　罫線の太さ
      Style : ;　　罫線形状
      Color : ;　　罫線色
      Op1 : Integer;　　オプション１
      Op2 : Integer;　　オプション２
      RX : Integer;　　Ｘ方向半径
      RY : Integer;　　Ｙ方向半径
  end;

  説明

  開始行、開始列、終了行、終了列は小数点以下も設定可能ですので
  微妙にずらしたい場合に小数点以下で調整してください。

  開始位置指定、終了位置指定は、
    Cns_LU = 1;　　罫線位置(左上)
    Cns_LM = 2;　　罫線位置(左中)
    Cns_LD = 3;　　罫線位置(左下)
    Cns_MU = 4;　　罫線位置(中上)
    Cns_MM = 5;　　罫線位置(中中)
    Cns_MD = 6;　　罫線位置(中下)
    Cns_RU = 7;　　罫線位置(右上)
    Cns_RM = 8;　　罫線位置(右中)
    Cns_RD = 9;　　罫線位置(右下)

  罫線の太さは、「2..標準,5..太い」を目安に設定してください。

  罫線形状は、psSolid:実線,psDash:破線,psDot:点線,psDashDot:一点鎖線,psDashDotDot:二点鎖線
  注意　実線以外は、太さ＝１のときのみ使用できるが、太さは解像度により変化させているため
  どうしても

  オプション１
   0:オプション無し,1:四角形描画,2:角が丸い四角形描画

  オプション２（現在未使用）

  Ｘ方向半径は、角が丸い四角形を描画する場合、水平方向の半径として使用
  Ｙ方向半径は、角が丸い四角形を描画する場合、垂直方向の半径として使用
  なお、半径は400Dpi時のピクセル数を表しており
  実際の印刷はプリンタの解像度により調整しています。

  例

  Const
  CnsHdLineSu = 5;
   PrnHdLineTbl : array [1..CnsHdLineSu] of Prn_Line_Inf = (
  (StGyo:1; StRetu:1;StP:Cns_MM;EndGyo:10;EndRetu:100;EndP:Cns_MM;Point:10;Style:psSolid; Color:clBlack;Op1:1),
  (StGyo:10;StRetu:1;StP:Cns_MM;EndGyo:1; EndRetu:100;EndP:Cns_MM;Point:0; Style:psDash; Color: clAqua;Op1:0),
  (StGyo:11;StRetu:1;StP:Cns_MM;EndGyo:20;EndRetu:100;EndP:Cns_MM;Point:0; Style:psDot; Color: clBlue;Op1:2;RX:100;RY:100),
  (StGyo:21;StRetu:1;StP:Cns_MM;EndGyo:30;EndRetu:100;EndP:Cns_MM;Point:0; Style:psDashDot;Color:clDkGray;Op1:1),
  (StGyo:1; StRetu:1;StP:Cns_MM;EndGyo:10;EndRetu:100;EndP:Cns_MM;Point:0; Style:psDashDot;Color:clGray;Op1:0)
  );

   CSPrint1.LinePrint(PrnHdLineTbl);


Prn_Header_Inf型

  リファレンス
  Prn_Header_Inf 型
  TCSPrint

  Prn_Header_Inf型は,ヘッダ印字情報を指定します。

  type
    Prn_Header_Inf = record
      Gyo : Currency;　　行
      Retu : Currency;　　列
      FontName : String; 　　フォント名
      Point : Integer; 　　文字サイズ 0..標準
      Title : String[250]; ヘッダ印字文字列
      Act : Integer; 　　Action番号
      FNm : String; 　　項目名
      EType : String; 編集タイプ
      EType2 : String; 参照ファイル項目の編集タイプ
      FStyles : ; 文字形状
  end;

  説明
  行、列は小数点以下も設定可能ですので
  微妙にずらしたい場合に小数点以下で調整してください。
  フォント名は標準のフォントと違う場合は設定してください。

  ヘッダ印字文字列にはシステム日時や頁番号も指定できます。
  なお、参照ファイル項目が日付型の場合、編集タイプにも指定できます。
Cns_GGEEMMDD | 年号YY年MM月DD日
Cns_GGEMD | 年号Y年M月D日
Cns_YYYYMMDDW | YYYY年MM月DD日(曜)
Cns_YYYYMDW | YYYY年M月D日(曜)
Cns_YYYYMMDD | YYYY年MM月DD日
Cns_YYMMDDW | YY年MM月DD日(曜)
Cns_YYMMDD | YY年MM月DD日
Cns_YYYYMMDDO | YYYY/MM/DD
Cns_YYMMDDO | YY/MM/DD
Cns_YYMMDDOHHMMSS | YY/MM/DD HH:MM:SS
Cns_YYMMDDOHHMM | YY/MM/DD HH:MM
Cns_YYYYMMDDHHMMSSO | YYYY/MM/DD HH:MM:SS
Cns_HHMM | HH:MM
Cns_HHMMSS | HH:MM:SS
Cns_PAGE | 頁番号

  参照ファイル項目の編集タイプには
CnsOraBool | OracleBoolean型(実際は数値)
CnsOraNum | Oracle数値
CnsOraChar | Oracle文字列
CnsOraDate | Oracle日付型
CnsOraDateTime | Oracle日付時間型
CnsOraTime | Oracle時間型

  を指定してください。

  例

  CnsHdStrSu = 11;
   PrnHdStrTbl : array [1..CnsHdStrSu] of Prn_Header_Inf = (
  (Gyo:1;Retu:1; Title: 'XXX000' ),
  (Gyo:1;Retu:10; Title: 'V1.0A' ),
  (Gyo:1;Retu:20; FontName:'ＭＳ　明朝';Point:18;Title:'※　ＸＸＸ一覧表　※';FStyles:[fsBold]),
  (Gyo:1;Retu:88; Title: Cns_YYMMDDOHHMM ),
  (Gyo:3;Retu:1; Title: 'XXXｺｰﾄﾞ' ),
  (Gyo:3;Retu:10; Title: '名称' ),
  (Gyo:3;Retu:40; Title: '単位' ),
  (Gyo:3;Retu:50; Title: '単価' ),
  (Gyo:3;Retu:60; Title: '数量' ),
  (Gyo:3;Retu:70; Title: '金額' ),
  (Gyo:3;Retu:80; Title: '備考' )
  );


Prn_Details_Inf型

  リファレンス
  Prn_Details_Inf 型
  TCSPrint

  Prn_Details_Inf型は,明細印字情報を指定します。

  type
    Prn_Details_Inf = record
      Gyo : Currency; 行
      Retu : Currency; 列
      FontName : String; フォント名
      Point : Integer; 文字サイズ
      TNm : String; 表名
      FNm : String; 項目名
      EType : String; 編集タイプ
      Act : Integer; Action番号
      EType2 : String; 参照ファイル項目の編集タイプ
      FStyles : ; 文字形状
      Work : String; ワーク領域
  end;

  説明
  行、列は小数点以下も設定可能ですので
  微妙にずらしたい場合に小数点以下で調整してください。
  フォント名は標準のフォントと違う場合は設定してください。

  参照ファイル項目が日付型の場合、編集タイプにも指定できます。
Cns_GGEEMMDD | 年号YY年MM月DD日
Cns_GGEMD | 年号Y年M月D日
Cns_YYYYMMDDW | YYYY年MM月DD日(曜)
Cns_YYYYMDW | YYYY年M月D日(曜)
Cns_YYYYMMDD | YYYY年MM月DD日
Cns_YYMMDDW | YY年MM月DD日(曜)
Cns_YYMMDD | YY年MM月DD日
Cns_YYYYMMDDO | YYYY/MM/DD
Cns_YYMMDDO | YY/MM/DD
Cns_YYMMDDOHHMMSS | YY/MM/DD HH:MM:SS
Cns_YYMMDDOHHMM | YY/MM/DD HH:MM
Cns_YYYYMMDDHHMMSSO | YYYY/MM/DD HH:MM:SS
Cns_HHMM | HH:MM
Cns_HHMMSS | HH:MM:SS

  参照ファイル項目の編集タイプには
CnsOraBool | OracleBoolean型(実際は数値)
CnsOraNum | Oracle数値
CnsOraChar | Oracle文字列
CnsOraDate | Oracle日付型
CnsOraDateTime | Oracle日付時間型
CnsOraTime | Oracle時間型

  を指定してください。

  表名は現在未使用


Prn_Level2_Inf型

  リファレンス
  Prn_Level2_Inf 型
  TCSPrint

  Prn_Level2_Inf型は,印字情報（新バージョン）を指定します。

  type
    Prn_Level2_Inf = record
      Gyo : Currency; 行
      Retu : Currency; 列
      FontName : String; フォント名
      Point : Integer; 文字サイズ
      Title : String[250]; 印字文字列
      Act : Integer; Action番号(参照ファイル読み込み)
      TNm : String; 表名
      FNm : String; 項目名
      EType : String; 編集タイプ
      EType2 : String; 参照ファイル項目の編集タイプ
      FStyles : ; 文字形状
      Work : String; 取得データ
      Names : String; IndexOfNameパターンのデータ
  end;

  説明
  行、列は小数点以下も設定可能ですので
  微妙にずらしたい場合に小数点以下で調整してください。
  フォント名は標準のフォントと違う場合は設定してください。

  ヘッダ印字文字列にはシステム日時や頁番号も指定できます。
  なお、参照ファイル項目が日付型の場合、編集タイプにも指定できます。
Cns_GGEEMMDD | 年号YY年MM月DD日
Cns_GGEMD | 年号Y年M月D日
Cns_YYYYMMDDW | YYYY年MM月DD日(曜)
Cns_YYYYMDW | YYYY年M月D日(曜)
Cns_YYYYMMDD | YYYY年MM月DD日
Cns_YYMMDDW | YY年MM月DD日(曜)
Cns_YYMMDD | YY年MM月DD日
Cns_YYYYMMDDO | YYYY/MM/DD
Cns_YYMMDDO | YY/MM/DD
Cns_YYMMDDOHHMMSS | YY/MM/DD HH:MM:SS
Cns_YYMMDDOHHMM | YY/MM/DD HH:MM
Cns_YYYYMMDDHHMMSSO | YYYY/MM/DD HH:MM:SS
Cns_HHMM | HH:MM
Cns_HHMMSS | HH:MM:SS
Cns_PAGE | 頁番号

  参照ファイル項目の編集タイプには
CnsOraBool | OracleBoolean型(実際は数値)
CnsOraNum | Oracle数値
CnsOraChar | Oracle文字列
CnsOraDate | Oracle日付型
CnsOraDateTime | Oracle日付時間型
CnsOraTime | Oracle時間型

  を指定してください。

  ワーク領域は参照ファイル項目の内容

  編集タイプに"NAMES"を指定すると参照ファイル項目の内容により
  IndexOfNameパターンの内容を印刷する。

  例
  Names='0=無し,1=有り'と指定すれば
  参照ファイルの項目の内容が0ならば"無し",1ならば"有り"と印刷する。
  なお、0,1以外の場合はなにも印刷しない。


TActionEvent型

  リファレンス
  TActionEvent 型
  TCSPrint

  TActionEvent型は,OnDAction,OnHActionで使用します。

  type TActionEvent = procedure(Sender: TObject; Act: Integer; var Text: string ) of object;

  説明
  Actには、Action番号が入り、Textには、実際に印刷する文字列をセットします。
  なお、編集タイプを設定しておいても、関係なくTextにセットした文字列のまま
  印字されますのでご注意ください。


  TCalButton

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TCalButton


プロパティ

  リファレンス
  TCalButton プロパティ
  TCalButton

  TCalButton

    MonthCalendar

    Format

    CalEdit

    CalLeft

    CalTop

    ParentMove

  TSpeedButton からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TCalButton メソッド
  TCalButton

  TCalButton

    Create

    Destroy

    Click

  TSpeedButton からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TCalButton イベント
  TCalButton

  TCalButton

  TControl からの継承


  TEGColumn

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TEGColumn


プロパティ

  リファレンス
  TEGColumn プロパティ
  TEGColumn

  TEGColumn

    Width

    FxHeight

    FxColor

    FxAlignment

    FxLayout

    FxFont

    FxText

    Height

    Color

    Alignment

    Layout

    Font

    EditType

    TrimFlg

    LineNo

    Lines

    ParentFont

    ParentFxFont

    DesignDisp

    Indent

    SkipFlg

  TCollectionItem からの継承


メソッド

  リファレンス
  TEGColumn メソッド
  TEGColumn

  TEGColumn

    Assign

    Create

    Destroy

  TCollectionItem からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TEGColumn イベント
  TEGColumn

  TEGColumn


  TEditGrid

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TEditGrid


プロパティ

  リファレンス
  TEditGrid プロパティ
  TEditGrid

  TEditGrid

    Columns

    NextEnter

    PriorKeyCode

    PriorName

    NextName

    FirstFlg

    FocusColor

  TStringGrid からの継承

  TCustomGrid からの継承

  TCustomControl からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TEditGrid メソッド
  TEditGrid

  TEditGrid

    Create

    Destroy

    DoEnter

    DoExit

    CanEditShow

    CreateEditor

    KeyDown

    KeyPress

    DrawCell

    SizeChanged

    PriorSetFocus

    NextSetFocus

    FirstSetFocus

    LastSetFocus

  TCustomDrawGrid からの継承

  TCustomGrid からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TEditGrid イベント
  TEditGrid

  TEditGrid

    OnCellReturn

  TCustomDrawGrid からの継承

  TWinControl からの継承

  TControl からの継承


TCellReturnEvent型

  リファレンス
  TCellReturnEvent 型
  TEditGrid

  TCellReturnEvent型は,OnCellReturnイベントで使用します。

  type TCellReturnEvent = procedure(Sender: TObject; ACol, ARow: Integer; var Key: Word) of object;

  説明
  Keyに0をセットすることにより、処理がキャンセルされます。


TTrimFlg型

  リファレンス
  TTrimFlg 型
  TEditGrid

  TTrimFlg型は,左右のスペースを取るか否かを指します。

  type TTrimFlg = (tfNone,tfTrimLeft,tfTrimRight,tfTrim);

  説明
  左右のスペースを取るか否かを指します

値 | 内容
------------- | --------------------
tfNone | なにもしない
tfTrimLeft | 左のスペースだけ取る
tfTrimRight | 右のスペースだけ取る
tfTrim | 左右のスペースを取る


  TKanaEdit

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TKanaEdit


プロパティ

  リファレンス
  TKanaEdit プロパティ
  TKanaEdit

  TKanaEdit

    TargetEdit

    KanaSyu

    NoChange

  TCustomEdit からの継承

  TWinWidgetControl からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TKanaEdit メソッド
  TKanaEdit

  TKanaEdit

    Create

    Destroy

    HuriganaSet

    HuriganaInit

  TCustomEdit からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TKanaEdit イベント
  TKanaEdit

  TKanaEdit

  TCustomEdit からの継承

  TWinControl からの継承

  TControl からの継承


TKanaSyu型

  リファレンス
  TKanaSyu 型
  TKanaEdit

  TKanaSyu型は,表示および取得するかなの種類を示します。

  type TKanaSyu = (ksHira, ksHanKata, ksZenKata);

  説明

  値　　　　　　説明

  ksHira　　　　ひらがな
  ksHanKata 　　半角カタカナ
  ksZenKata 　　全角カタカナ


  TMCCBoxEx

  シーエス作成コンポーネント　Copyright(C)シーエス


  継承

        |

  TMCCBoxEx


プロパティ

  リファレンス
  TMCCBoxEx プロパティ
  TMCCBoxEx

  TMCCBoxEx

    CanEdit

    Columns

    TargetColumn

    Indent

    InputName

    TargetInput

    DropDownFlg

    MaxLength

    ImeMode

    ImeName

    RefMode

    SelectedText

  TCustomComboBoxからの継承

  TCustomCombo からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TMCCBoxEx メソッド
  TMCCBoxEx

  TMCCBoxEx

    Create

    ChangeIndex

    ChangeItem

    Destroy

    SearchIndex

  TCustomComboBox からの継承

  TCustomCombo からの継承

  TCustomListControl からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TMCCBoxEx イベント
  TMCCBoxEx

  TCustomCombo からの継承

  TWinControl からの継承

  TControl からの継承


TMCCBoxExRefMode型

リファレンス
  TMCCBoxExRefMode 型
  TMCCBoxEx

  TMCCBoxExRefMode 型は，TScrollBoxExコンポーネントに貼り付けられた場合，Refreshメソッド発行時に
  TMCCBoxExコンポーネントがどういう風に動作するかを示します。

  type TMCCBoxExRefMode = (rmNormal, rmChangeItem, rmSearchIndex);

  説明
  次の表に TMCCBoxExRefMode 型に指定できる値を示します。

    値　　　意味

    rmNormal　　何もしない
    rmChangeItem　　ChangeItemメソッドを発行
    rmSearchIndex　SearchIndexメソッドを発行


  TNumEdit

  シーエス作成コンポーネント　Copyright(C)シーエス


  継承

        |

  TNumEdit


プロパティ

  リファレンス
  TNumEdit プロパティ
  TNumEdit

  TNumEdit

    CanUndo

    Modified

    SelLength

    SelStart

    ValText

    RAutoSize

    Alignment

    AutoSelect

    AutoSize

    BorderStyle

    BottomMargin

    Comma

    DecimalFixed

    DecimalLength

    DesignText

    DisabledColor

    HideSelection

    IntegerFixed

    IntegerLength

    LeftMargin

    LeftMark

    Minus

    ReadOnly

    RightMargin

    RightMark

    Text

    TopMargin

    VertAlignment

    ZeroFixed

  TCustomControlからの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TNumEdit メソッド
  TNumEdit

  TNumEdit

    Create

    Destroy

    Clear

    ClearSelect

    ClearSelection

    ClearUndo

    CopyToClipboard

    CutToClipboard

    PasteFromClipboard

    SelectAll

    Undo

  TCustomControlからの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TNumEdit イベント
  TNumEdit

  TNumEdit

    OnChange

  TWinControl からの継承

  TControl からの継承


TVertAlignment型

リファレンス
  TVertAlignment 型
  TNumEdit

  TVertAlignment 型は，テキストがコントロール内でどのように揃えられるかを指定します。

  type TVertAlignment = (taTopJustify, taBottomJustify, taVCenter);

  説明
  次の表に TVertAlignment 型に指定できる値を示します。

    値　　　意味

    taTopJustify　　テキストは上揃えされる。
    taVCenter　　テキストはコントロールの中央に配置される
    taBottomJustify　テキストは下揃えされる。


  TScrollBoxEx

  シーエス作成コンポーネント　Copyright(C)シーエス


  継承

        |

  TScrollBoxEx


プロパティ

  リファレンス
  TScrollBoxEx プロパティ
  TScrollBoxEx

  TScrollBoxEx

    ColorLabel

    DefFontColor

    DefFontDisplay

    EndFirstFlg

    FocusColor

    FocusColorChange

    FunctionFlg

    ItemButton

    ItemDisplay

    ItemHeight

    ItemIndex

    ItemLabel

    ItemMax

    Items

    MakeCount

    MCCBoxExRefresh

    NameTables

    NextEnter

    NextName

    NextStop

    NextTab

    PriorKeyCode

    PriorName

    PriorStop

    PriorUp

    SKipReadOnly

    TableOut

    UseBrushColor

    UseName

    UseShimaColor

    UseShimaFlg

  TScrollBox からの継承

  TScrollingWinControl からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TScrollBoxEx メソッド
  TScrollBoxEx

  TScrollBoxEx

    CompoTo

    Create

    Destroy

    FirstSetFocus

    GetItemIndexNo

    GetTableCompo

    ItemsTo

    LastSetFocus

    NextSetFocus

    PriorSetFocus

    Refresh

  TScrollingWinControl からの継承

  TWinControl からの継承

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


  使用可能コンポーネント

  TNumEdit

  TMCCBoxEx

  TTextMarge
  TKanaEdit


イベント

  リファレンス
  TScrollBoxEx イベント
  TScrollBoxEx

  TScrollBoxEx

    OnKeyDown

  TWinControl からの継承

  TControl からの継承


  TTextMarge

  シーエス作成コンポーネント　Copyright(C)シーエス


   継承

        |

  TTextMarge


プロパティ

  リファレンス
  TTextMarge プロパティ
  TTextMarge

  TTextMarge

    CompoName1

    CompoName2

    Text

  TControl からの継承

  TComponent からの継承


メソッド

  リファレンス
  TTextMarge メソッド
  TTextMarge

  TTextMarge

    Create

    Destroy

  TControl からの継承

  TComponent からの継承

  TPersistent からの継承

  TObject からの継承


イベント

  リファレンス
  TTextMarge イベント
  TTextMarge

  TTextMarge

    OnSetText

    OnGetText

  TControl からの継承


TMargeEvent型

  リファレンス
  TMargeEvent 型
  TTextMarge

  TMargeEvent型は,OnSetText,OnGetTextで使用します。

  type TMargeEvent = procedure(Sender: TObject; Sender1, Sender2 : ; var Text: string ) of object;

  説明
  OnGetTextイベントでは、Textに文字列を指定してください。
  OnSetTextイベントでは、Textの内容をコンポーネントに反映させてください。


  イベントリファレンス

  シーエス作成コンポーネント　Copyright(C)シーエス


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:31 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:31 -0000 vti_filesize:IR|266 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|TCBColumn vti_title:SR|TCBColumn vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


OnDAction

  リファレンス
  TCSPrint.OnDAction
  TCSPrint

  OnDActionイベントは,明細を印刷するときAction番号に0以外が入っていた場合に発生します。

  property OnDAction: TActionEvent;

  説明
  普通には記述できない編集パターンや参照ファイル項目以外を印刷する場合などで
  お使いください。

  例

  if Act = 1 then
   Text := EditStartYMD.Text;
  if Act = 2 then
   Text := EditEndYMD.Text;


OnHAction

  リファレンス
  TCSPrint.OnHAction
  TCSPrint

  OnHActionイベントは,ヘッダを印刷するときAction番号に0以外が入っていた場合に発生します。

  property OnHAction: TActionEvent;

  説明
  普通には記述できない編集パターンや参照ファイル項目以外を印刷する場合などで
  お使いください。

  例

  if Act = 1 then
   Text := EditStartYMD.Text;
  if Act = 2 then
   Text := EditEndYMD.Text;


OnSetText

  リファレンス
  TTextMarge.OnSetText
  TTextMarge

  OnSetTextイベントは,Textプロパティに設定した時に発生します。

  type
    TMargeEvent = procedure(Sender: TObject; Sender1, Sender2 : TControl; var Text: string ) of object;

  property OnSetText: TMargeEvent;

  説明
  引数TextをSender1およびSender2のコンポーネントに分割してそれぞれセットする
  コードを記述してください。

  例
  TStaticText(Sender1).Caption := Copy(Text,1,3);
  TStaticText(Sender2).Caption := Copy(Text,4,7);


OnGetText

  リファレンス
  TTextMarge.OnGetText
  TTextMarge

  OnGetTextイベントは,Textプロパティを取得した時に発生します。

  type
    TMargeEvent = procedure(Sender: TObject; Sender1, Sender2 : TControl; var Text: string ) of object;

  property OnGetText: TMargeEvent;

  説明
  引数TextにSender1およびSender2のコンポーネントをつなぎ合わせた文字列を設定する
  コードを記述してください。

  例
  Text := TStaticText(Sender1).Caption + TStaticText(Sender2).Caption;


OnCellReturn

  リファレンス
  TEditGrid.OnCellReturn
  TEditGrid

  OnCellReturnイベントは,NextEnterプロパティが真でセルでEnterが押された場合や
  PriorKeyCodeプロパティに指定されたキーが押された場合や→，←，↑，↓が押された場合に発生します。

  type TCellReturnEvent = procedure(Sender: TObject; ACol, ARow: Integer; var Key: Word) of object;

  property OnCellReturn: TCellReturnEvent;

  説明
  AColが今いる列，ARowが今いる行を示します。
  Keyがキーコード、VK_RETURN,VK_LEFT,VK_RIGHT,VK_UP,VK_DOWN
  またはPriorKeyCodeプロパティに指定されたものがありえます。
  Keyに0を設定するとセル間の移動は発生しません。


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:31 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:31 -0000 vti_filesize:IR|266 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|TMCCBoxEx vti_title:SR|TMCCBoxEx vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


OnChange

  リファレンス
  TNumEdit.OnChange
  TNumEdit

  OnChange イベントは，編集コントロールのテキストに変更が加えられたときに発生します。

  property OnChange: TNotifyEvent;

  説明
  OnChange イベントハンドラは，編集コントロールのテキストが変更されたときに指定された動作をします。
  実際に変更が行われたかを知るには Modified プロパティを使います。
  このイベントが発生した時点で編集コントロールの Text プロパティはすでに更新されています。
  このイベントを使用して，編集コントロールにユーザーが入力した変更に反応することができます。


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:30 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:30 -0000 vti_filesize:IR|264 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|TNumEdit vti_title:SR|TNumEdit vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:31 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:31 -0000 vti_filesize:IR|1174 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000066.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/イベントリファレンス/TNumEdit/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/イベントリファレンス/TNumEdit/..\\\\..\\\\社内コンポーネント\\\\SD00000066.htm vti_cachedtitle:SR|OnChange vti_title:SR|OnChange vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


OnkeyDown

  リファレンス
  TScrollBoxEx.OnKeyDown
  TScrollBoxEx

  OnKeyDown イベントは，子コンポーネントにフォーカスがあるときにユーザーがキーを押すと発生します。

  type

    TKeyEvent = procedure (Sender: TObject; var Key: Word; Shift: TShiftState) of object;

  property OnKeyDown: TKeyEvent;

  説明
  OnKeyDown イベントハンドラを使うと，キーが押されたときに実行される特殊な処理を指定できます。OnKeyDown ハンドラは，
  ファンクションキーや〔Shift〕，〔Alt〕，〔Ctrl〕と組み合わされたキーを含めたすべてのキーボードキーに応答できます。
  TKeyEvent 型は，キーボードイベントを処理するメソッドを指します。
  Key パラメータは，キーボード上のキーです。英数字以外のキーでは，仮想キーコードを使って押されたキーを判別できます。
  詳細については，「仮想キーコード」を参照してください。
  なお、〔Page Up〕キーおよび〔PageDown〕キーはScrollBoxExコンポーネント内部で処理されているのでキーを押してもイベントは発生しません。
  但し、Key=VK_PRIORは先頭項目で↑キーなど前に戻るキーを
  Key=VK_NEXTは最終項目でエンターキーなど先に進むキーを押された場合にこのイベントが発生します。

  Shift パラメータは，〔Shift〕，〔Alt〕，または〔Ctrl〕がキー入力と組み合わされているかどうかを示します。


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:26 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:26 -0000 vti_filesize:IR|272 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|TScrollBoxEx vti_title:SR|TScrollBoxEx vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:30 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:30 -0000 vti_filesize:IR|1898 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000001.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/イベントリファレンス/TScrollBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/イベントリファレンス/TScrollBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000001.htm vti_cachedtitle:SR|OnkeyDown vti_title:SR|OnkeyDown vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


  プロパティリファレンス

  シーエス作成コンポーネント　Copyright(C)シーエス


Alignment

リファレンス
  TCBColumn.Alignment
  TCBColumn

  Alignment プロパティは，列内でどのようにテキストを揃えるかを指定します。

  property Alignment: ;

  説明
  Alignment プロパティを使うと，値を列の左揃え，右揃え，中央揃えのどれにするかを指定できます。
  次の表に，Alignment に指定できる値を示します。

    値　　　意味

    taLeftJustify　列の左側に文字を揃える
    taCenter　　列の中央に文字を揃える
    taRightJustify　列の右側に文字を揃える


Color

リファレンス
  TCBColumn.Color
  TCBColumn

  Color プロパティは，列の背景色を指定します。

  property Color: ;

  説明
  Color プロパティはドロップダウンリスト列の背景色を指定します。
  Color は Graphics ユニットで定義される定数（clBlue など）の 1 つに設定するか
  明示的な RGB 整数値に設定することができます。


Font

リファレンス
  TCBColumn.Font
  TCBColumn

  Font プロパティは，列にデータを表示するときに使うフォントを制御します。

  property Font: TFont;

  説明
  Font プロパティは，列に表示されるテキストの書体の属性を決める TFont オブジェクトを指します。

  注意　バージョンによっては使用できないことがあります。


ParentColor

リファレンス
  TCBColumn.ParentColor
  TCBColumn

  ParentColor プロパティは，コントロールの色情報を探す場所を決めます。

  property ParentColor: Boolean;

  説明
  コントロールが親コンポーネントと同じ色を使うにするには，ParentColor を true に設定します。
  ParentColor が false の場合，コントロールは自身の Color プロパティを使用します。
  すべてのコントロールで ParentColor を true に設定すると，フォーム上のすべてのコントロールを同じ外観にできます。
  たとえば，フォーム上のすべてのコントロールの ParentColor が true の場合，フォームの背景色を灰色に変更すると，
  そのフォーム上のすべてのコントロールの背景も灰色になります。

  コントロールの Color プロパティを変更すると，ParentColor は自動的に false になります。


ParentFont

リファレンス
  TCBColumn.ParentFont
  TCBColumn

  ParentFont プロパティは，コントロールのフォント情報を探す場所を決めます。

  property ParentFont: Boolean;

  説明
  コントロールが親コンポーネントと同じフォントを使うにするには，ParentFont を true に設定します。
  ParentFont が false の場合，コントロールは自身の Font プロパティを使用します。
  すべてのコントロールで ParentFont を true に設定すると，フォーム上のすべてのコントロールを同じ外観にできます。
  たとえばフォーム内のすべてのコントロールの ParentFont を 12 ポイントの Courier に指定すると，
  フォーム上のすべてのコントロールがそのフォントを使用するようになります。
  コントロールの Font プロパティを変更すると，ParentFont は自動的に false になります。

  フォームの ParentFont が true ならば，そのフォームはデフォルトフォントを使います。

  注意　バージョンによっては使用できないことがあります。


TagString

リファレンス
  TCBColumn.TagString
  TCBColumn

  TagString プロパティは，列を使って任意の文字列を格納します。

  property TagString: Integer;

  説明
  TagString プロパティの使用目的は，特に決められていません。
  開発者の便宜を図るために用意されています。
  TagString プロパティを使って追加の文字列の格納や列に登録すべきデータベースのフィールド名
  などを格納します。


Width

リファレンス
  TCBColumn.Alignment
  TCBColumn

  Width プロパティは，列の幅を示します。

  property Width: Integer;

  説明
  Width プロパティは列の幅をピクセル単位で指定します。
  Width プロパティを0にすることにより、表示しないようにすることもできます。


BackBmp

  リファレンス
  TCSPrint.BackBmp
  TCSPrint

  BackBmpプロパティは,背景を印刷するときにビットマップを指定するときに使います。

  property BackBmp: string;

  説明
  ここにビットマップファイルを指定するとBackPaintメソッドで背景を印刷するときに
  ブラシの模様を指定されたビットマップファイルのデータを使用します。
  イメージが 8×8 ピクセル以上ある場合，左上の 8×8 の領域のみが使われます。

  注意　プリンタの解像度に合わせて細かくなってしまうため、プリンタによっては
  イメージが違うかもしれません。


BackColor

  リファレンス
  TCSPrint.BackColor
  TCSPrint

  BackColorプロパティは,背景色を指定できます。

  property BackColor: ;

  説明
  BackBmpプロパティで有効なファイル名が登録されていないかぎり
  BackPaintメソッドで背景を印刷するときにここで指定された色で印刷されます。


BackColorS

  リファレンス
  TCSPrint.BackColorS
  TCSPrint

  BackColorSプロパティは,プレビュー画面の背景色を指定できます。

  property BackColorS: ;

  説明
  BackBmpプロパティで有効なファイル名が登録されていないかぎり
  BackPaintメソッドで背景をプレビュー表示するときにここで指定された色で表示されます。


Copies

  リファレンス
  TCSPrint.Copies
  TCSPrint

  Copiesプロパティは,印刷部数できます。

  property Copies: Integer;

  説明
  印刷部数を指定できます。
  但し、プリンタが複数部数の印刷をサポートしていない場合は１部しか印刷されません。


DDataSet

  リファレンス
  TCSPrint.DDataSet
  TCSPrint

  DDataSetプロパティは,明細印刷用データベースデータセットを指定できます。

  property DDataSet: TDataSet;

  説明
  DetailPrintメソッドおよびDetailPrintOメソッドで印刷するときに
  参照するデータセットを指定してください。


Direct

  リファレンス
  TCSPrint.Direct
  TCSPrint

  Directプロパティは,印刷データをテキストデータとして
  溜め込むか否かを指定できます。

  property Direct: Boolean;

  説明
  真にすると、NewPageメソッドで１頁分のデータが指定されると
  すぐにプリンタに送ります。
  この場合、PrintPageTextメソッドは使用できません。


FontN

  リファレンス
  TCSPrint.FontN
  TCSPrint

  FontNプロパティは,基準フォントの名前を示します。

  property FontN: string;

  説明
  このフォントの大きさで行の高さ、列の幅が決まります。


FontS

  リファレンス
  TCSPrint.FontS
  TCSPrint

  FontSプロパティは,基準となる列の幅をポイントで指定できます。

  property FontS: integer;

  説明
  FontNプロパティのフォントでFontSプロパティのポイントで算出された
  画面およびプリンタでの幅により水平方向の印刷開始位置が決まります。


FontSH

  リファレンス
  TCSPrint.FontSH
  TCSPrint

  FontSHプロパティは,行の高さをポイントで指定できます。

  property FontSH: integer;

  説明
  FontNプロパティのフォントでFontSHプロパティのポイントで算出された
  画面およびプリンタでの高さにより垂直方向の印刷開始位置が決まります。


FormName

  リファレンス
  TCSPrint.FormName
  TCSPrint

  FormNameプロパティは,用紙の種類をフォーム名で指定できます。

  property FormName: string;

  説明
  WindowsNTの場合のみ、プリンタに登録済みおよびフォームの登録で指定された
  フォーム名により用紙を指定できます。
  プリンタに定義済みの用紙はそれぞれ特定の番号が
  付けられているのでその番号を指定することもできるので
  他のＯＳはこの番号を指定してください。
  尚、この場合、PSizeプロパティには、"フォーム名"と設定してください。


HDataSet

  リファレンス
  TCSPrint.HDataSet
  TCSPrint

  HDataSetプロパティは,明細印刷用データベースデータセットを指定できます。

  property HDataSet: TDataSet;

  説明
  HeaderPrintメソッドおよびHeaderPrintOメソッドで印刷するときに
  参照するデータセットを指定してください。


LeftMargin

  リファレンス
  TCSPrint.LeftMargin
  TCSPrint

  LeftMarginプロパティは,印刷するときの左余白をピクセルで指定できます。

  property LeftMargin: integer;

  説明
  罫線を左端に印刷するとき実際には右側しか印刷されないので
  細くなってしまうので、そういう場合は指定したほうがよい。


MaxColumn

  リファレンス
  TCSPrint.MaxColumn
  TCSPrint

  MaxColumnプロパティは,実際に印刷できる最大列数を取得できます。

  property MaxColumn: integer;

  説明
  PrintInitメソッドを実行後、値がセットされます。

  例　とあるプリンタの用紙サイズと列数
 | 縦 | 横
Ａ４ | 110 | 159
Ｂ４ | 135 | 194
Ａ３ | 159 | 228


MaxLine

  リファレンス
  TCSPrint.MaxLine
  TCSPrint

  MaxLineプロパティは,実際に印刷できる行数を取得できます。

  property MaxLine: integer;

  説明
  PrintInitメソッドを実行後、値がセットされます。

  例　とあるプリンタの用紙サイズと行数
 | 縦 | 横
Ａ４ | 67 | 46
Ｂ４ | 82 | 56
Ａ３ | 96 | 67


PageEtype

  リファレンス
  TCSPrint.PageEtype
  TCSPrint

  PageEtypeプロパティは,頁番号の編集パターンを指定できます。

  property PageEtype: string;

  説明
  頁番号を印刷するときに使う編集パターンを指定してください。

  編集パターン
  9 数字0から9までを表示
  Z 前から0の場合は変わりにスペースを表示
  - 前から0の場合は変わりにスペースを表示(但し、マイナスの場合は前にマイナスを表示)
  . 小数点を表す（但し、小数点以下がすべてZまたは-でスペースの場合は表示しない）
  , 主に３桁ごとに挿入する（但し、Zまたは-でスペースの場合は表示しない)

  例
  999
  9999
  ZZZ9


PageNo

  リファレンス
  TCSPrint.PageNo
  TCSPrint

  PageNoプロパティは,現在印刷中の頁番号を取得できます。

  property PageNo: Integer;

  説明
  はじめは１でNewPageメソッドが発行されるたびにインクリメントされます。


PaintColor

  リファレンス
  TCSPrint.PaintColor
  TCSPrint

  PaintColorプロパティは,ペイントする色を指定できます。

  property PaintColor: ;

  説明
  PrintPメソッドでペイントするときにここで指定された色で印刷されます。
  但し、$02fefefe（初期値）を指定した場合は、プリンタの解像度により
  均一になるように操作されます。


PaintColorS

  リファレンス
  TCSPrint.PaintColorS
  TCSPrint

  PaintColorSプロパティは,プレビュー画面にペイントする色を指定できます。

  property PaintColorS: ;

  説明
  PrintPメソッドでプレビュー画面にペイントするときにここで指定された色で表示されます。


PaperMode

  リファレンス
  TCSPrint.PaperMode
  TCSPrint

  PaperModeプロパティは,プリンタのマップモードを指定できます。

  property PaperMode: integer;

  説明
  通常はMM_TEXT(1)を指定してください。


PaperTray

  リファレンス
  TCSPrint.PaperTray
  TCSPrint

  PaperTrayプロパティは,給紙位置を指定できます。

  property PaperTray: string;

  説明
  "DMBIN_UPPER" 　上用紙トレイ
  "DMBIN_MIDDLE" 　中用紙トレイ
  "DMBIN_LOWER" 　下用紙トレイ
  "DMBIN_MANUAL" 　手差し用紙フィーダ
  "DMBIN_ONLYONE"　単一用紙ソース
  "DMBIN_AUTO"　　 自動用紙選択
  と、プリンタに定義済みの給紙位置はそれぞれ特定の番号が
  付けられているのでその番号を指定してください。


PColor

  リファレンス
  TCSPrint.PColor
  TCSPrint

  PColorプロパティは,カラープリンタでカラーかモノクロを指定できます。

  property PColor: integer;

  説明
  通常はDMCOLOR_MONOCHROME(1)を指定してください。


PDuplex

  リファレンス
  TCSPrint.PDuplex
  TCSPrint

  PDuplexプロパティは,両面印刷可能なプリンタで両面印刷のタイプを指定できます。

  property PDuplex: integer;

  説明
  DMDUP_SIMPLEX(1) 　両面印刷しない
  DMDUP_VERTICAL(2) 　横（長辺）
  DMDUP_HORIZONTAL(3) 　縦（短辺）


PName

  リファレンス
  TCSPrint.PName
  TCSPrint

  PNameプロパティは,プリンタ名を指定できます。

  property PName: string;

  説明
  プリンタ名を指定してください。
  Nilまたは存在しないプリンタが指定された場合は
  選択のためのダイアログがPrintInitメソッド発行時に
  表示されます。


POri

  リファレンス
  TCSPrint.POri
  TCSPrint

  POriプロパティは,用紙の方向を指定できます。

  property POri: string;

  説明
  "縦" 縦向き
  "横" 横向き


PQuality

  リファレンス
  TCSPrint.PQuality
  TCSPrint

  PQualityプロパティは,印刷品質を指定できます。

  property PQuality: string;

  説明
  "高" 高品質
  "中" 中品質
  "低" 低品質
  "ド" ドラフト
  と、品質をDpiで指定できます。


PResolvX

  リファレンス
  TCSPrint.PResolvX
  TCSPrint

  PResolvXプロパティは,水平方向の解像度(Dpi)が取得できます。

  property PResolvX: integer;

  説明
  PrintInitメソッドを実行後、値がセットされます。


PResolvY

  リファレンス
  TCSPrint.PResolvY
  TCSPrint

  PResolvYプロパティは,垂直方向の解像度(Dpi)できます。

  property PResolvY: integer;

  説明
  PrintInitメソッドを実行後、値がセットされます。


Preview

  リファレンス
  TCSPrint.Preview
  TCSPrint

  Previewプロパティは,プレビューを表示するか否かを指定できます。

  property Preview: boolean;

  説明
  真にすると、印刷をせずに、プレビュー画面が表示されます。


PSize

  リファレンス
  TCSPrint.PSize
  TCSPrint

  PSizeプロパティは,用紙サイズを指定できます。

  property PSize: string;

  説明
  "A4" 　Ａ４サイズ
  "A3" 　Ａ３サイズ
  "B4" 　Ｂ４サイズ
  "A5" 　Ａ５サイズ
  "B5" 　Ｂ５サイズ
  "ユーザー定義" 　PSizeX,PSizeYプロパティにて用紙の大きさを指定
  "フォーム名" 　FormNameプロパティにて用紙の大きさを指定


PSizeX

  リファレンス
  TCSPrint.PSizeX
  TCSPrint

  PSizeXプロパティは,ユーザー定義の幅をピクセルで指定できます。

  property PSizeX: integer;

  説明
  尚、この場合、PSizeプロパティには、"ユーザー定義"と設定してください。


PSizeY

  リファレンス
  TCSPrint.PSizeY
  TCSPrint

  PSizeYプロパティは,ユーザー定義の幅をピクセルで指定できます。

  property PSizeY: integer;

  説明
  尚、この場合、PSizeプロパティには、"ユーザー定義"と設定してください。


RightTrim

  リファレンス
  TCSPrint.RightTrim
  TCSPrint

  RightTrimプロパティは,編集パターンの文字列を右寄せで印刷するか否かを指定できます。

  property RightTrim: Boolean;

  説明
  真の場合、明細およびヘッダーを印刷する場合、数値を編集パターンで
  編集された文字列の右空白を取り、右寄せで印刷します。

  例
  編集パターン"ZZZZ9.ZZ"に100をセットすると通常"△△△１００△△△"と印刷されるが
  真に設定すると"△△△△△△１００"と印刷されるようになる。(△は空白）


ScrMax

  リファレンス
  TCSPrint.ScrMax
  TCSPrint

  ScrMaxプロパティは,プレビューのフォームの大きさをスクリーン画面サイズに
  あわせるか否かを指定できます。

  property ScrMax: Boolean;

  説明
  真にするとプレビュー画面の大きさをスクリーン画面サイズにします。


ShowDialog

  リファレンス
  TCSPrint.ShowDialog
  TCSPrint

  ShowDialogプロパティは,実際に印刷するときに頁指定等ができるダイアログを
  表示するか否かを指定できます。

  property ShowDialog: Boolean;

  説明
  真にすると、プレビュー画面でメニューから印刷を選択したり、直に印刷する前に
  頁指定等ができるダイアログを表示します。


Title

  リファレンス
  TCSPrint.Title
  TCSPrint

  Titleプロパティは,タイトルを指定できます。

  property Title: string;

  説明
  プレビュー画面のタイトル欄およびプリンタに出力される場合の
  ドキュメント名に設定されます。


TopMargin

  リファレンス
  TCSPrint.TopMargin
  TCSPrint

  TopMarginプロパティは,印刷するときの上余白をピクセルで指定できます。

  property TopMargin: integer;

  説明
  罫線を上端に印刷するとき実際には下側しか印刷されないので
  細くなってしまうので、そういう場合は指定したほうがよい。


MonthCalendar

  リファレンス
  TCalButton.MonthCalendar
  TCalButton

  MonthCalendarプロパティは,ボタンが押されたときに開くMonthCalendarコンポーネントを指定します。

  property MonthCalendar : TMonthCalendar;

  説明
  指定されたMonthCalendarコンポーネントはフォームに貼り付けてください。
  他のコンポーネントに貼り付けると表示されない可能性があります。


Format

  リファレンス
  TCalButton.Format
  TCalButton

  Formatプロパティは,日付時刻形式文字列を指定してください。

  property Format : string;

  説明
  MonthCalendarコンポーネントで選択された日付を文字列に変換するための
  日付時刻形式文字列を指定してください。
  内部でFormatDateTime関数を使用しています。


CalEdit

  リファレンス
  TCalButton.CalEdit
  TCalButton

  CalEditプロパティは,対象のEditコンポーネントを指定してください。

  property CalEdit : TEdit;

  説明
  MonthCalendarコンポーネントで選択された日付を文字列に変換しセットする
  Editコンポーネントを設定してください。


CalLeft

  リファレンス
  TCalButton.CalLeft
  TCalButton

  CalLeftプロパティは,MonthCalendarコンポーネントを表示する水平位置を指定できます。

  property CalLeft : Integer;

  説明
  MonthCalendarコンポーネントを表示する水平位置を設定してください。


CalTop

  リファレンス
  TCalButton.CalTop
  TCalButton

  CalTopプロパティは,MonthCalendarコンポーネントを表示する垂直位置を指定できます。

  property CalTop : Integer;

  説明
  MonthCalendarコンポーネントを表示する垂直位置を設定してください。


ParentMove

  リファレンス
  TCalButton.ParentMove
  TCalButton

  ParentMoveプロパティは,MonthCalendarコンポーネントを表示する位置を
  ボタンのすぐ下にするか否かを指定できます。

  property ParentMove : Boolean;

  説明
  真に設定すると、MonthCalendarコンポーネントはすぐ下の位置に表示されます。


Width

  リファレンス
  TEGColumn.Width
  TEGColumn

  Widthプロパティは,列の幅を設定できます。

  property Width: Integer;

  説明
  列の幅を指定することができます。


FxHeight

  リファレンス
  TEGColumn.FxHeight
  TEGColumn

  FxHeightプロパティは,スクロールしない行の高さを設定できます。

  property FxHeight: Integer;

  説明
  スクロールしない行の高さを指定できます。


FxColor

  リファレンス
  TEGColumn.FxColor
  TEGColumn

  FxColorプロパティは,スクロールしない行の背景色を設定できます。

  property FxColor: ;

  説明
  スクロールしない行の背景色はFxColorプロパティにより変更することができます。


FxAlignment

  リファレンス
  TEGColumn.FxAlignment
  TEGColumn

  FxAlignmentプロパティは,スクロールしない行の左右の揃えを設定できます。

  property FxAlignment: ;

  説明
  スクロールしない行の左右の揃えを指定することができます。


FxLayout

  リファレンス
  TEGColumn.FxLayout
  TEGColumn

  FxLayoutプロパティは,スクロールしない行の上下の揃えを設定できます。

  property FxLayout: ;

  説明
  スクロールしない行の上下の揃えを指定することができます。


FxFont

  リファレンス
  TEGColumn.FxFont
  TEGColumn

  FxFontプロパティは,スクロールしない行のフォントを設定できます。

  property FxFont:

  説明
  スクロールしない行のフォントを指定することができます。


FxText

  リファレンス
  TEGColumn.FxText
  TEGColumn

  FxTextプロパティは,スクロールしない行の表示文字列を設定できます。

  property FxText: string;

  説明
  スクロールしない行の表示文字列を指定することができます。


Height

  リファレンス
  TEGColumn.Height
  TEGColumn

  Heightプロパティは,スクロールする行の高さを設定できます。

  property Height: Integer;

  説明
  スクロールする行の高さを指定することができます。


Color

  リファレンス
  TEGColumn.Color
  TEGColumn

  Colorプロパティは,スクロールする行の背景色を設定できます。

  property Color: ;

  説明
  スクロールする行の背景色を指定することができます。


Alignment

  リファレンス
  TEGColumn.Alignment
  TEGColumn

  Alignmentプロパティは,スクロールする行の左右の揃えを設定できます。

  property Alignment: TAlignment;

  説明
  スクロールする行の左右の揃えを指定することができます。


Layout

  リファレンス
  TEGColumn.Layout
  TEGColumn

  Layoutプロパティは,スクロールする行の上下の揃えを設定できます。

  property Layout: TTextLayout;

  説明
  スクロールする行の上下の揃えを指定することができます。


Font

  リファレンス
  TEGColumn.Font
  TEGColumn

  Fontプロパティは,スクロールする行のフォントを設定できます。

  property Font: TFont;

  説明
  スクロールする行のフォントを指定することができます。


EditType

  リファレンス
  TEGColumn.EditType
  TEGColumn

  EditTypeプロパティは,スクロールする行のセルを表示するときに数値編集するパターンを設定できます。

  property EditType: string;

  説明
  スクロールする行のセルを表示するときに数値編集するパターンを設定できます。

  パターン
  9 数字0から9までを表示
  Z 前から0の場合は変わりにスペースを表示
  - 前から0の場合は変わりにスペースを表示(但し、マイナスの場合は前にマイナスを表示)
  . 小数点を表す（但し、小数点以下がすべてZまたは-でスペースの場合は表示しない）
  , 主に３桁ごとに挿入する（但し、Zまたは-でスペースの場合は表示しない)

  例
  ZZZZZZZ9
  ZZZZZZZZ
  -------9
  --------
  \\\\\\\9
  \\\\\\\\
  ZZZZZZZ9.9
  ZZZZZZZ9.99
  ZZZZZZZ9.999
  ZZZZZZZ9.9999
  ZZZZZZZZ.ZZ
  -------9.99
  --------.--
  ZZ,ZZZ,ZZ9
  ZZ,ZZZ,ZZZ
  --,---,--9
  --,---,---
  \\,\\\,\\9
  \\,\\\,\\\
  ZZ,ZZZ,ZZ9.99
  ZZ,ZZZ,ZZZ.ZZ
  --,---,--9.99
  --,---,---.--


TrimFlg

  リファレンス
  TEGColumn.TrimFlg
  TEGColumn

  TrimFlgプロパティは,編集後の前後のスペースを取るか否かを設定できます。

  property TrimFlg: TTrimFlg;

  説明
  編集後の前後のスペースを取るか否かを指定することができます。

値 | 内容
------------- | --------------------
tfNone | なにもしない
tfTrimLeft | 左のスペースだけ取る
tfTrimRight | 右のスペースだけ取る
tfTrim | 左右のスペースを取る

,,,


LineNo

  リファレンス
  TEGColumn.LineNo
  TEGColumn

  LineNoプロパティは,スクロールする行の表示を行Noに固定するか否かを設定できます。

  property LineNo: Boolean;

  説明
  Trueにすることにより行Noがセルに表示されます。


Lines

  リファレンス
  TEGColumn.Lines
  TEGColumn

  Linesプロパティは,スクロールしない列でスクロールする行の表示と
  DesignDispプロパティがTrueのときに表示するスクロールする列で
  スクロールする行のデザイン時の表示を設定できます。

  property Lines: TStringList;

  説明
  スクロールしない列では、スクロールする行の表示の内容を指定できます。
  スクロールする列では、DesignDispプロパティがTrueのときに表示する
  デザイン用表示文字列を指定できます。


ParentFont

  リファレンス
  TEGColumn.ParentFont
  TEGColumn

  ParentFontプロパティは,スクロールする行のフォント情報を探す場所を決めます。

  property ParentFont: Boolean;

  説明
  コントロールがTEditGridコンポーネントと同じフォントを使うにするには，ParentFont を true に設定します。
  ParentFont が false の場合，コントロールは自身の Font プロパティを使用します。


ParentFxFont

  リファレンス
  TEGColumn.ParentFxFont
  TEGColumn

  ParentFxFontプロパティは,スクロールする行のフォント情報を探す場所を決めます。

  property ParentFxFont: Boolean;

  説明
  コントロールがTEditGridコンポーネントと同じフォントを使うにするには，ParentFont を true に設定します。
  ParentFont が false の場合，コントロールは自身の Font プロパティを使用します。


DesignDisp

  リファレンス
  TEGColumn.DesignDisp
  TEGColumn

  DesignDispプロパティは,デザイン時にスクロールする行のセルに文字列を表示するか否かを設定できます。

  property DesignDisp: Boolean;

  説明
  Trueに指定し、Linesプロパティに文字列を登録するとデザイン時にスクロールする行のセルに文字列を表示します。


Indent

  リファレンス
  TEGColumn.Indent
  TEGColumn

  Indentプロパティは,セルを右揃えまたは左揃えで表示する場合の余白の幅を設定できます。

  property Indent: Integer;

  説明
  セルを右揃えまたは左揃えで表示する場合の余白の幅を指定することができます。


SkipFlg

  リファレンス
  TEGColumn.SkipFlg
  TEGColumn

  SkipFlgプロパティは,スクロールする行のこの列のセルを編集できるか否かを設定できます。

  property SkipFlg: Boolean;

  説明
  Trueにするとこの列のセルは編集することができなくなり
  Enter等で移動する場合もスキップされます。


Columns

  リファレンス
  TEditGrid.Columns
  TEditGrid

  Columnsプロパティは,列の情報を設定できます。

  property Columns[Index : Integer]: TEGColumn;


NextEnter

  リファレンス
  TEditGrid.NextEnter
  TEditGrid

  NextEnterプロパティは,Enterで次の列に移動できるか否かを設定できます。

  property NextEnter: Boolean;

  説明
  TrueにするとEnterで次の列に移動できるようになります。


PriorKeyCode

  リファレンス
  TEditGrid.PriorKeyCode
  TEditGrid

  PriorKeyCodeプロパティは,前の列に移動できるキーコードを設定できます。

  property PriorKeyCode: Word;

  説明
  0以外のキーコードを設定するとそのキーコードに対応するキーが押された場合
  前の列に移動します。


PriorName

  リファレンス
  TEditGrid.PriorName
  TEditGrid

  PriorNameプロパティは,スクロールする行の１行目でそれより前の列に移動できない場合に
  フォーカスを移すコントロールを設定できます。

  property PriorName : TControl;

  説明
  スクロールする行の１行目でそれより前の列に移動できない場合に
  フォーカスを移すコントロールを設定できます。


NextName

  リファレンス
  TEditGrid.NextName
  TEditGrid

  NextNameプロパティは,スクロールする行の最下行でそれより次の列に移動できない場合に
  フォーカスを移すコントロールを設定できます。

  property NextName : TControl;

  説明
  スクロールする行の最下行でそれより次の列に移動できない場合に
  フォーカスを移すコントロールを設定できます。


FirstFlg

  リファレンス
  TEditGrid.FirstFlg
  TEditGrid

  FirstFlgプロパティは,このグリッドにフォーカスが移ってきた場合
  スクロールする行の１行目の最初の編集できる項目に移動するか否かを設定できます。

  property FirstFlg : Boolean;

  説明
  Trueとした場合、このグリッドにフォーカスが移ってきた場合
  スクロールする行の１行目の最初の編集できる項目に移動します。


FocusColor

  リファレンス
  TEditGrid.FocusColor
  TEditGrid

  FocusColorプロパティは,編集中のセルの背景色を設定できます。

  property FocusColor: ;

  説明
  編集中のセルの背景色を指定することができます。


TargetEdit

  リファレンス
  TKanaEdit.TargetEdit
  TKanaEdit

  TargetEditプロパティは,対象となるEditコンポーネントを指定できます。

  property TargetEdit: TCustomEdit;

  説明
  IMEかな変換のかな文字を取得するEditコンポーネントを設定してください。


KanaSyu

  リファレンス
  TKanaEdit.KanaSyu
  TKanaEdit

  KanaSyuプロパティは,表示および取得できるかな種別を指定できます。

  property KanaSyu: TKanaSyu;

  説明

  値　　　　　　説明

  ksHira　　　　ひらがな
  ksHanKata 　　半角カタカナ
  ksZenKata 　　全角カタカナ


NoChange

  リファレンス
  TKanaEdit.NoChange
  TKanaEdit

  NoChangeプロパティは,一時的に修正されたくないときに指定できます。

  property NoChange: Boolean;

  説明
  真にセットすると、対象のEditコンポーネントで文字列を入力しても反映されません。

  例
  新規登録のときは真に、修正のときは偽にセットする。
  と、修正のときは、手作業で修正することになる。


CanEdit

リファレンス
  TMCCBoxEx.CanEdit
  TMCCBoxEx

  CanEdit プロパティは，テキストを変更できるかどうかを示します。

  property CanEdit: Boolean;

  説明
  CanEdit プロパティは，テキストを変更できるかどうかを取得できます。


Columns

リファレンス
  TMCCBoxEx.Columns
  TMCCBoxEx

  Columnsプロパティは，TMCCBoxExに入っているすべてのカラム情報を示します。

  property Columns[Index: Integer]: TCBColumn;

  説明
  Columnsプロパティは，ドロップダウンしたときのカラム情報に直接アクセスするために使います。
  Index を 0 にすれば一番左のカラム情報を示し，Index を 1 にすれば 2 番目のカラム情報を示します。
  各ページは TCBColumn オブジェクトです。


TargetColumn

リファレンス
  TMCCBoxEx.TargetColumn
  TMCCBoxEx

  TargetColumnプロパティは，編集ボックスに表示するカラムを示します。

  property TargetColumn : Byte;

  TargetColumnプロパティは，編集ボックスに表示するカラム№を指します。


Indent

リファレンス
  TMCCBoxEx.Indent
  TMCCBoxEx

  Indentプロパティは，ドロップダウンリストに表示する場合の余白を指定できます。

  property Indent : Integer;

  Indentプロパティをセットすると，ドロップダウンリストに表示するカラムの内容の前または後ろに余白を
  指定したピクセル数分空けることができます。


InputName

リファレンス
  TMCCBoxEx.InputName
  TMCCBoxEx

  InputNameプロパティは，関連付けされたコンポーネントを指定します。

  property InputName: TControl；

  InputNameプロパティに指定されたコンポーネントの内容を元にChangeItemメソッドでItemIndexプロパティを設定したり
  ChangeIndexメソッドでコンポーネントの内容を変更したりできます。

  セットできるコンポーネント

  TEdit
  TNumEdit
  TStaticText
  TLabel
  TTextMarge

  例および使用方法

  上のMCCBoxExコンポーネントは左のNumEditコンポーネントに連動しています。
  MCCBoxExコンポーネントのドロップダウンリストで選択するとNumEditコンポーネントの内容が変化し
  NumEditコンポーネントの内容を変化させるとMCCBoxExコンポーネントも対応する内容に変化する。
  注意　NumEditコンポーネントのOnChangeイベント内にMCCBoxEx1.ChangeItemイベントを記述しています。

  下のMCCBoxExコンポーネントは右のStaticTextコンポーネントに連動しています。
  MCCBoxExコンポーネントのドロップダウンリストで選択したり編集ボックスに文字入力すると
  とStaticTextコンポーネントの内容が変化する。


TargetInput

リファレンス
  TMCCBoxEx.TargetInput
  TMCCBoxEx

  TargetInputプロパティは，InputNameプロパティのコンポーネントに表示するカラムを示します。

  property TargetInput : Byte;

  TargetInputプロパティは，InputNameプロパティのコンポーネントに表示するカラム№を指します。
  なお、255をセットすることにより，ItemIndexプロパティの内容とリンクします。


DropDownFlg

リファレンス
  TMCCBoxEx.DropDownFlg
  TMCCBoxEx

  DropDownFlgプロパティは，ドロップダウンで選択されたときにエンターキーでKeyDownイベントを
  発生させるかどうかを示します。

  property DropDownFlg : Boolean;

  DropDownFlgプロパティがTrueの場合，ドロップダウンで選択されたときにエンターキーでKeyDownイベントを
  発生させます。


MaxLength

リファレンス
  TMCCBoxEx.MaxLength
  TMCCBoxEx

  MaxLength プロパティは，編集ボックス部分にユーザーが入力できる文字の最大数を指定します。

  property MaxLength: Integer;

  説明
  MaxLength プロパティを使うと，編集ボックス部分にユーザーが入力できる文字の数を限定できます。
  MaxLength プロパティの値が 0 の場合は，文字数についてアプリケーション定義の制限がありません。

  注意　MaxLength を設定しても，既存のテキストは切り捨てられません。
          設定以後に，MaxLength の文字数制限を超える文字を追加できなくなるだけです。
  注意　MaxLength が 0 の場合でも，編集コントロールに入力できる文字数は，
          オペレーティングシステムにより制限されることがあります。


ImeMode

リファレンス
  TMCCBoxEx.ImeMode
  TMCCBoxEx

  ImeMode プロパティは，IME（かな漢字変換プログラム）の動作を指定します。

  property ImeMode: TImeMode;

  説明
  ImeMode プロパティを設定すると，IME がユーザーのキー入力を処理する方法を設定できます。
  IME とは，アジア地域言語の文字を処理するためのフロントエンド入力プロセッサです。
  IME はすべてのキーボード入力を受け取り，変換ウィンドウでアジア地域の文字に変換し，
  変換後の文字または文字列を Delphi アプリケーションに送ります。
  ImeMode プロパティでは，IME が実行する変換の種類について，コントロールが受け入ける入力に
  応じて適切な種類に変更できます。たとえば，数値入力のみを受け入けるコントロールでは，
  変換処理は不要なので，ImeMode プロパティを imClose に設定できます。

  注意　ImeMode プロパティの値は，コントロールがフォーカスを受け取ったときのみ有効になります。
          コントロールにすでに入力フォーカスがある場合に，ImeMode プロパティの値を変更するには，SetIme メソッドを呼び出します。


ImeName

リファレンス
  TMCCBoxEx.ImeName
  TMCCBoxEx

  ImeName プロパティは，キーボード入力をアジア地域言語の文字に変換する場合に使う IME（かな漢字変換プログラム）を指定します。

  type TImeName = type string;
  property ImeName: TImeName;

  説明
  ImeName プロパティを設定すると，キー入力の変換に使う IME を指定できます。IME は，アジア地域言語の文字を処理するフロントエンド入力プロセッサです。IME はすべてのキーボード入力を受け取り，変換ウィンドウでアジア地域の文字に変換し，変換後の文字または文字列を Delphi アプリケーションに送ります。
  ImeName プロパティには，Windows コントロールパネルでインストールされている IME の 1 つを指定しなければなりません。プロパティインスペクタを使うと，システムにインストール済みのすべての IME を収めたドロップダウンリストを表示できます。実行時には，インストール済みの IME のリストをアプリケーションで Screen グローバル変数から取得できます。

  ImeName プロパティに利用できない IME を指定すると，かわりに，アプリケーションの起動時にアクティブだった IME が使われます。例外は生成されません。

  注意　ImeName プロパティの値は，コントロールがフォーカスを受け取ったときのみ有効になります。コントロールにすでに入力フォーカスがある場合に ImeName プロパティの値を変更するには，SetIme メソッドを呼び出します。


RefMode

リファレンス
  TMCCBoxEx.RefMode
  TMCCBoxEx

  RefModeプロパティは，TScrollBoxExコンポーネントに貼り付けられた場合，Refreshメソッド発行時に
  TMCCBoxExコンポーネントがどういう風に動作するかを示します。

  property RefMode : TMCCBoxExRefMode;

  TScrollBoxExコンポーネントに貼り付けられた場合，Refreshメソッド発行時に
  RefModeプロパティをrmChangeItemにセットした場合，ChangeItemメソッドを発行し
  RefModeプロパティをrmSerachIndexにセットした場合，SearchIndexメソッドを発行する。

    値　　　意味

    rmNormal　　何もしない
    rmChangeItem　　ChangeItemメソッドを発行
    rmSearchIndex　SearchIndexメソッドを発行


SelectedText

リファレンス
  TMCCBoxEx.SelectedText
  TMCCBoxEx

  SelectedText プロパティは，編集ボックスに表示している文字列を示します。

  property SelectedText : string;

  説明
  SelectedText プロパティは，編集ボックスに表示している文字列を取得できます。


CanUndo

リファレンス
  TNumEdit.CanUndo
  TNumEdit

  CanUndo プロパティは，取り消し可能な変更が編集コントロールに入っているかどうかを示します。

  property CanUndo: Boolean;

  説明
  CanUndo プロパティを読み出すと，テキストに対して加えた変更内容が Undo メソッドを呼び出すことによって
  取り消すことができるかどうかを判別できます。変更を加えるようなコマンドに相応するメニュー項目を有効にしたり
  無効にしたりするときに役立ちます。


Modified

リファレンス
  TNumEdit.Modifued
  TNumEdit

  Modified プロパティは，ユーザーが編集コントロールのテキストを編集したかどうかを示します。

  property Modified: Boolean;

  説明
  Modified プロパティは，編集コントロールの Text が変更されたかどうかを調べます。Text プロパティをプログラムで直接変更する場合，
  Modified プロパティも True に設定しなければなりません。


SelLength

リファレンス
  TNumEdit.SelLength
  TNumEdit

  SelLength プロパティは，選択されている文字の数（バイト数）を指定します。

  property SelLength: Integer;

  説明
  SelLength プロパティは，選択されているテキストの長さをバイト数で調べます。
  この値は，マルチバイト文字を使っていない限り，文字数と同じです。
  SelLength を設定すると，選択の内容を SelStart から始まる，SelLength で指定したバイト数の長さの文字列に変更できます。

  注意　 SelLength の値を SelStart が示す文字からテキストの最後までの文字数よりも大きく設定すると SelStart からテキストの最後までのすべての文字が選択されます。SelLength の値を利用できる文字数よりも大きく設定した後に SelLength を参照すると，設定した値ではなく実際に選択されている文字の長さが返されます。


SelStart

リファレンス
  TNumEdit.SelStart
  TNumEdit

  SelStart プロパティは，テキスト選択の先頭文字の位置を指定します。

  property SelStart: Integer;

  説明
  SelStart プロパティは，範囲選択されている文字列の開始位置を調べます。
  編集コントロールの先頭位置は 0 です。
  選択されているテキストがない場合，SelStart はカーソル位置を示します。
  SelStart を設定すると現在の選択範囲はクリアされ，指定した文字の直前にカーソルを置くことができます。
  特定の範囲のテキストを選択するには，まず SelStart を設定してカーソル位置を決め，SelLength を使って選択範囲を指定します。


ValText

リファレンス
  TNumEdit.ValText
  TNumEdit

  ValText プロパティは，コントロールに関連付けられている表示テキスト文字列を保持します。

  property ValText: String;

  説明
  ValText プロパティは，コントロールの 表示テキスト文字列 を取得することができます。


RAutoSize

リファレンス
  TNumEdit.RAutoSize
  TNumEdit

  RAutoSize プロパティは，実行時にテキストに合わせて編集コントロールの幅を自動的に変更するかどうかを決定します。

  property RAutoSize: Boolean;

  説明
  RAutoSize プロパティはクライアント領域の幅をテキストに合わせるように編集コントロールのサイズを調整するのに使います。
  実行時にRAutoSize が False であれば，編集コントロールの幅は固定です。
  実行時にRAutoSize が True であれば，フォントや境界線のスタイル変更のようにコントロールの幅に
  影響する変更が発生したときにコントロールのサイズが再調節されます。

  注意　デザイン時に編集コントロールの幅を自動的に変更したい場合は，AutoSizeプロパティを使用してください。


Alignment

リファレンス
  TNumEdit.Alignment
  TNumEdit

  Alignment プロパティは，ラベル内でのテキストの横方向の配置を制御します。

  property Alignment: ;

  説明
  Alignment プロパティを設定すると，ラベルコントロールの ClientRect 内でラベルのテキストを位置合わせする方法を指定できます。


AutoSelect

リファレンス
  TNumEdit.AutoSelect
  TNumEdit

  AutoSelect プロパティは，編集コントロールがフォーカスを得たときにコントロールのすべてのテキストを自動的に選択するかどうかを決定します。

  property AutoSelect: Boolean;

  説明
  編集コントロールがフォーカスを得たときにすべてのテキストを選択するには AutoSelect を True にします。
  編集コントロールの内容が追加されるよりも置換される場合の方が多いと思われるときに AutoSelect を使います。


AutoSize

リファレンス
  TNumEdit.AutoSize
  TNumEdit

  AutoSize プロパティは，デザイン時にテキストに合わせて編集コントロールの幅を自動的に変更するかどうかを決定します。

  property AutoSize: Boolean;

  説明
  AutoSize プロパティはクライアント領域の幅をテキストに合わせるように編集コントロールのサイズを調整するのに使います。
  デザイン時AutoSize が False であれば，編集コントロールの幅は固定です。
  デザイン時AutoSize が True であれば，フォントや境界線のスタイル変更のようにコントロールの幅に影響する変更が発生したときにコントロールのサイズが再調節されます。


BorderStyle

リファレンス
  TNumEdit.BorderStyle
  TNumEdit

  BorderStyle プロパティは，編集コントロールがクライアント領域の周囲に単一線の境界をもつかどうかを決定します。

  property BorderStyle: ;

  説明
  BorderStyleプロパティは，編集コントロールのクライアント領域の外観を変更することができます。BorderStyle の値は bsSingle または bsNone です。BorderSyle が bsSingle の場合，編集コントロールは周囲に単一線の境界を持ちます。BorderStyle が bsNone の場合，境界はありません。


BottomMargin

リファレンス
  TNumEdit.BottomMargin
  TNumEdit

  BottomMargin プロパティは，編集コントロールの枠の下の端と表示テキスト文字列の下の端までの距離をピクセル数で指定します。

  property BottomMargin: Integer;

  説明
  マージンは，編集コントロールの枠の端と表示テキスト文字列の端の間のスペースです。


Comma

リファレンス
  TNumEdit.Comma
  TNumEdit

  Commaプロパティは，表示テキスト文字列を編集するときに３桁ごとにカンマ（，）を配置するかどうかを示します。

  property Comma: Boolean;

  説明
  CommaプロパティがTrueの場合、表示テキスト文字列が変更されたときに、３桁ごとにカンマをつける編集を行う。

  例
  NumEdit1.Comma=False
  NumEdit2.Comma=True


DecimalFixed

リファレンス
  TNumEdit.DecimalFixed
  TNumEdit

  DecimalFixedプロパティは，表示テキスト文字列を編集するときに小数点以下を固定桁数として表示するか否かを示します。

  property DecimalFixed: Boolean;

  説明
  DecimalFixedプロパティがTrueの場合、表示テキスト文字列を編集するときに小数点以下を固定桁数として表示します。
  DecimalFixedプロパティがFalseの場合、表示テキスト文字列を編集するときに小数点以下を可変桁数として表示します。

  例

  NumEdit1.DecimalFixed=Trueで1.234と入力した場合

  NumEdit1.DecimalFixed=Falseで1.234と入力した場合


DecimalLength

リファレンス
  TNumEdit.DecimalLength
  TNumEdit

  DecimalLength プロパティは，ユーザーが編集コントロールに入力できる小数桁の最大長を指定します。

  property DecimalLength: Integer;

  説明
  DecimalLength プロパティを使うと，編集コントロールに入力できる小数桁の最大文字数を指定できます。


DesignText

リファレンス
  TNumEdit.DesignText
  TNumEdit

  DesignTextプロパティは，デザイン時に表示するテキスト文字列を保持します。

  property DesignText : string;

  説明
  DesignTextプロパティは，デザイン時にのみ表示するテキスト文字列を設定できます。
  このテキスト文字列は，Commaプロパティなどの編集用プロパティとは一切関係なくそのまま表示されます。


DisabledColor

リファレンス
  TNumEdit.DisabledColor
  TNumEdit

  DisabledColorプロパティは，マウス，キーボード，タイマーのいずれかのイベントに応答しない場合の表示テキスト文字列の
  色情報を指定できます。

  property DisabledColor: ;

  説明
  DisabledColorプロパティは，EnabledプロパティがFalseの場合の色情報( )を設定できます。


HideSelection

リファレンス
  TNumEdit.HideSelection
  TNumEdit

  HideSelection プロパティは，フォーカスが他のコントロールに移動した場合でもテキストが範囲選択された状態の表示を続けるかどうかを決定します。

  property HideSelection: Boolean;

  説明
  HideSelection プロパティを False に設定すると編集コントロールがフォーカスを持たない状態でもテキストが選択されたときと同じ長方形領域を描画したままにします。
  HideSelection を True に設定すると編集コントロールがフォーカスを持っている場合にのみ選択された長方形領域を描画します。
  HideSelection は選択の実際の値には無関係で，その視覚的な表示にのみ影響します。
  常に HideSelection を False にしておくと編集コントロールの多いフォームが見づらくなる場合があります。


IntegerFixed

リファレンス
  TNumEdit.IntegerFixed
  TNumEdit

  IntegerFixedプロパティは，表示テキスト文字列を編集するときに整数を固定桁数として表示するか否かを示します。

  property IntegerFixed: Boolean;

  説明
  IntegerFixedプロパティがTrueの場合、表示テキスト文字列を編集するときに整数を固定桁数として表示します。
  IntegerFixedプロパティがFalseの場合、表示テキスト文字列を編集するときに整数を可変桁数として表示します。

  例

  NumEdit1.IntegerFixed=True
  NumEdit1.LeftMark='LEFT'
  NumEdit1.RightMark='RIGHT'
  NumEdit2.IntegerFixed=False
  NumEdit2.LeftMark='LEFT'
  NumEdit2.RightMark='RIGHT'


IntegerLength

リファレンス
  TNumEdit.IntegerLength
  TNumEdit

  IntegerLength プロパティは，ユーザーが編集コントロールに入力できる整数桁の最大長を指定します。

  property IntegerLength: Integer;

  説明
  IntegerLength プロパティを使うと，編集コントロールに入力できる整数桁の最大文字数を指定できます。


LeftMargin

リファレンス
  TNumEdit.LeftMargin
  TNumEdit

  LeftMargin プロパティは，編集コントロールの枠の左の端と表示テキスト文字列の左の端までの距離をピクセル数で指定します。

  property LeftMargin: Integer;

  説明
  マージンは，編集コントロールの枠の端と表示テキスト文字列の端の間のスペースです。


LeftMark

リファレンス
  TNumEdit.LeftMark
  TNumEdit

  LeftMarkプロパティは，編集コントロールの表示テキスト文字列の左に付加する文字列を指定します。

  property LeftMark: string;

  説明
  LeftMarkプロパティに文字列を設定すると表示テキスト文字列の一番左に常にその文字列が付加されます。

  例

  NumEdit1.LeftMark='合計金額'


Minus

リファレンス
  TNumEdit.Minus
  TNumEdit

  Minusプロパティは，マイナスの入力可能か否かを示します。

  property Minus: Boolean;

  説明
  MinusプロパティがTrueの場合、マイナス記号（-）を受付、表示する。


ReadOnly

リファレンス
  TNumEdit.ReadOnly
  TNumEdit

  ReadOnly プロパティは，ユーザーが編集コントロールのテキストを変更できるかどうかを決定します。

  property ReadOnly: Boolean;

  説明
  編集コントロールを表示のみに制限するには ReadOnly プロパティを True に設定します。
  編集コントロールでの編集を可能にするには ReadOnly を False に設定します。
  ReadOnly を True に設定するとテキストの変更はできなくなりますが，テキストの選択はできます。
  選択されたテキストをアプリケーションによって操作したり，クリップボードにコピーしたりすることができます。


RightMargin

リファレンス
  TNumEdit.RightMargin
  TNumEdit

  RightMargin プロパティは，編集コントロールの枠の右の端と表示テキスト文字列の右の端までの距離をピクセル数で指定します。

  property RightMargin: Integer;

  説明
  マージンは，編集コントロールの枠の端と表示テキスト文字列の端の間のスペースです。


RightMark

リファレンス
  TNumEdit.RightMark
  TNumEdit

  RightMarkプロパティは，編集コントロールの表示テキスト文字列の右に付加する文字列を指定します。

  property RightMark: string;

  説明
  RightMarkプロパティに文字列を設定すると表示テキスト文字列の一番右に常にその文字列が付加されます。

  例

  NumEdit1.RightMark='ドル'


Text

リファレンス
  TNumEdit.Text
  TNumEdit

  Text プロパティは，コントロールに関連付けられているテキスト文字列を保持します。

  property Text: String;

  説明
  Text プロパティは，コントロールの Text を取得したり，Text 値に新しい文字列を指定したりすることができます。
  Text 値は数字文字列です。


TopMargin

リファレンス
  TNumEdit.TopMargin
  TNumEdit

  TopMargin プロパティは，編集コントロールの枠の上の端と表示テキスト文字列の上の端までの距離をピクセル数で指定します。

  property TopMargin: Integer;

  説明
  マージンは，編集コントロールの枠の端と表示テキスト文字列の端の間のスペースです。


VertAlignment

リファレンス
  TNumEdit.VertAlignment
  TNumEdit

  VertAlignment プロパティは，編集コントロール内のテキストを揃える方法を指定します。

  property VertAlignment: TVertAlignment;

  説明
  VertAlignment プロパティを使うと，編集コントロールでテキストを揃える方法を変更できます。VertAlignment は以下の値のいずれかをとることができます。

    値　　　意味

    taTopJustify　　テキストは上揃えされる。
    taVCenter　　テキストはコントロールの中央に配置される
    taBottomJustify　テキストは下揃えされる。


ZeroFixed

リファレンス
  TNumEdit.ZeroFixed
  TNumEdit

  ZeroFixedプロパティは，表示テキスト文字列を編集するときに前スペースの変わりにゼロ（0）をセットするかどうか示します。

  property ZeroFixed : Boolean;

  説明
  ZeroFixedプロパティがTrueの場合、表示テキスト文字列が変更されたときに前スペースの変わりにゼロ（0）をセットします。

  例
  NumEdit1.ZeroFixed=True


ColorLabel

リファレンス
  TScrollBoxEx.ColorLabel
  TScrollBoxEx

  ColorLabel プロパティは，テキストデータの代わりに色情報を持つことで行単位に背景色を
  設定することができます。

  property　ColorLabel: ;

  説明
  ColorLabel プロパティの指定する コンポーネントの
  Captionプロパティに色情報( )を指定することで
   コンポーネントの背景色を変化させることができます。

  使用方法
  ScrollBoxExに情報をセットする

  Label1.Caption := IntToStr( TColor 型の色指定コード );
  ScrollBoxEx1.CompoTo( WrkIdx );

  ScrollBoxExから情報を取り出すとき

  ScrollBoxEx1.ItemsTo( WrkIdx );
  Label1.Color := StrToIntDef( Label1.Caption, clWhite );
  Label1.Font.Color := Label1.Color;

  注意：フォントの色にも同じ色をセットしないと色指定コードがそのまま表示されます。

  例
  ScrollBoxEx1.ColorLabel = Label1

  procedure TForm1.FormShow(Sender: TObject);
  Const
    CnsColor : Array[0..7] of TColor =
    ( clWhite, clRed, clLime, clYellow, clBlue, clFuchsia, clAqua, clSilver );
  var
    WrkIdx : Integer;
  begin
    for WrkIdx := 0 to 7 do
    begin
     Label1.Caption := IntToStr(CnsColor[WrkIdx]);
     ScrollBoxEx1.CompoTo(WrkIdx);
    end;
    ScrollBoxEx1.ItemIndex := -1;
    ScrollBoxEx1.Refresh;
  end;


DefFontColor

  リファレンス
  TScrollBoxEx.DefFontColor
  TScrollBoxEx

  DefFontColor プロパティは、DefFontDisplayプロパティが真のとき
  表示明細エリアの文字の色指定コードを指定することができます。

  property DefFontColor: ;

  説明
  DefFontColor プロパティは、DefFontDisplayプロパティが真のとき
  表示明細エリアの文字の色指定コードを変化させます。

  使用方法および例


DefFontDisplay

  リファレンス
  TScrollBoxEx.DefFontDisplay
  TScrollBoxEx

  DefFontDisplay プロパティは表示明細エリアの文字の色指定コードを制御することができます。

  property DefFontDisplay: Boolean;

  説明
  DefFontDisplay プロパティが真のとき、表示明細エリアの文字の色指定コードをDefFontColorプロパティの値に設定します。

  使用方法および例
  ScrollBoxEx1.DefFontColor = clBtnFace
  ScrollBoxEx1.DefFontDisplay = True


EndFirstFlg

  リファレンス
  TScrollBoxEx.EndFirstFlg
  TScrollBoxEx

  EndFirstFlg プロパティは入力の最初または最後を越えた場合，OnKeyDownイベントを
  発生させるか否かを指定できます。

  property EndFirstFlg: Boolean;

  説明
  EndFirstFlg プロパティが真のときは入力の最初または最後を越えた場合
  OnKeyDownイベントを発生させます。最初の項目でそれより前に移動しようとした場合
  Key=VK_PRIORで、最後の項目でそれより後に移動しようとした場合、Key=VK_NEXTでイベントが発生します。
  なお、PriorName プロパティにコンポーネントが設定されていた場合でItemIndexプロパティが0だった場合は
  イベントは発生せずに、設定されているコンポーネントにフォーカスが移動します。
  また、NextName プロパティにコンポーネントが設定されていた場合でItemIndexプロパティがItemMax プロパティ- 1だった場合は
  イベントは発生せずに、設定されているコンポーネントにフォーカスが移動します。

  注意
  コンポーネント内部でVK_NEXT(PageDown)、VK_PRIOR(PageUp)はスクロールボックス内を１画面単位で
  スクロールするために使用していますので、キーが押されたことによるOnKeyDownイベントは発生しません。


FocusColor

  リファレンス
  TScrollBoxEx.FocusColor
  TScrollBoxEx

  FocusColor プロパティは、入力明細エリアの文字入力中の子コンポーネントの背景色の色指定コードを
  設定することができます。

  property FocusColor: ;

  説明
  FocusColor プロパティは、FocusColorChangeプロパティが真のとき
  入力明細エリアの文字入力中の子コンポーネントの背景色の色指定コードを設定することができます。


FocusColorChange

  リファレンス
  TScrollBoxEx.FocusColorChange
  TScrollBoxEx

  FocusColorChangeプロパティは子コンポーネントの背景色の制御をするか否かを指定できます。

  property FocusColorChange: Boolean;

  説明
  FocusColorChangeプロパティが真のとき入力明細エリアの文字入力中の子コンポーネントの背景色が
  FocusColorプロパティに変化します。

  使用方法および例
  ScrollBoxEx1.FocusColor = clYellow
  ScrollBoxEx1.FocusColorChange = True


FunctionFlg

  リファレンス
  TScrollBoxEx.FunctionFlg
  TScrollBoxEx

  FunctionFlgプロパティは子コンポーネントでファンクションキーが押された場合
  OwnerコンポーネントにOnKeyDownイベントを発生させるか否かを指定できます。

  property FunctionFlg: Boolean;

  説明
  FunctionFlgプロパティが真の場合はESCおよびファンクションキーが押された場合
  OwnerコンポーネントにKeyDownメッセージを送信する。

  尚、OwnerコンポーネントがFormの場合、KeyPreviewプロパティを真にしていると
  ２回OnkeyDownイベントが発生するので注意すること。


ItemButton

  リファレンス
  TScrollBoxEx.ItemButton
  TScrollBoxEx

  ItemButtonプロパティは表示明細エリアにボタンコンポーネントを表示させるか否かを
  指定できます。

  property ItemButton: Boolean;

  説明
  ItemButtonプロパティが真の場合，表示明細エリアにボタンコンポーネントも表示させる


ItemDisplay

  リファレンス
  TScrollBoxEx.ItemDisplay
  TScrollBoxEx

  ItemDisplayプロパティは表示明細エリアの表示の仕方を指定できます。

  property ItemDisplay: Boolean;

  説明
  ItemDisplayプロパティが真の場合，表示明細エリアにItemsプロパティに存在する分だけ表示させ
  偽の場合，Itemsプロパティに存在しなくても空白を表示する。

  使用方法および例
  ScrollBoxEx1.ItemDisplay = True

  ScrollBoxEx1.ItemDisplay = False


ItemHeight

  リファレンス
  TScrollBoxEx.ItemHeight
  TScrollBoxEx

  ItemHeightプロパティは明細１行分の縦方向のサイズをピクセル数で指定します。

  property ItemHeight: Integer;

  説明
  ItemHeightプロパティは明細１行分の高さを取得、変更できます。


ItemIndex

  リファレンス
  TScrollBoxEx.ItemIndex
  TScrollBoxEx

  ItemIndexプロパティは入力明細の位置を指定します。

  property ItemIndex: Integer;

  説明
  ItemIndexプロパティを変更することで子コンポーネントの位置が変化します。

  尚、(-1)を指定することですべて表示明細にすることもできます。


ItemLabel

  リファレンス
  TScrollBoxEx.ItemLabel
  TScrollBoxEx

  ItemLabel プロパティは， コンポーネントの表示の仕方を制御できます。

  property ItemLabel: Boolean;

  説明
  ItemLabel プロパティを真にすることで コンポーネントは表示明細エリアでも
  入力明細エリアと同様の表示をさせることができる。


ItemMax

  リファレンス
  TScrollBoxEx.ItemMax
  TScrollBoxEx

  ItemMaxプロパティは明細の表示できる行数を指定します。

  property ItemMax: Integer;

  説明
  ItemMaxプロパティを変更することで表示、入力可能な行数を取得、変更できます。


Items

  リファレンス
  TScrollBoxEx.Items
  TScrollBoxEx

  Items プロパティは，項目の表示内容を保存しておくエリアです。

  property Items: ;

  説明
  項目の表示内容はItemsToイベントで子コンポーネントにセットされ
  CompoToイベントで子コンポーネントからItemsプロパティにセットされる。


MakeCount

  リファレンス
  TScrollBoxEx.MakeCount
  TScrollBoxEx

  MakeCountプロパティは子コンポーネントの数を示します。

  property MakeCount: Integer;

  説明
  MakeCountプロパティはControlCountプロパティと同じだが，オブジェクトインスペクタで確認できるように
  定義してある。


MCCBoxExRefresh

  リファレンス
  TScrollBoxEx.MCCBoxExRefresh
  TScrollBoxEx

  MCCBoxExRefreshプロパティはMCCBoxEX子コンポーネントの状態を制御をするか否かを指定できます。

  property MCCBoxExRefresh: Boolean;

  説明
  ScrollBoxExコンポーネントがRefreshされたとき，MCCBoxExRefreshプロパティが真の場合に
  子コンポーネントに存在するMCCBoxExコンポーネントのRefModeプロパティがrmChangeItemならば
  MCCBoxEx.ChangeItemメソッドを発行し、rmSearchIndexならばMCCBoxEx.SearchIndexメソッドを発行します。


NameTables

  リファレンス
  TScrollBoxEx.NameTables
  TScrollBoxEx

  NameTables プロパティは，コンポーネントの入力順や対応するDBの列名などを保存しておくエリアです。

  property NameTables: ;

  説明
  本来なら下位オブジェクトを作成してそのプロパティを作成するところですが
  この時点ではまだやりかたがわからなくて（笑）、テキスト形式でプロパティ定義をしています。

  第１項目　オブジェクト名
  この項目の前に"+"をつけると、エンターキーなどでの移動のときスキップします。

  第２項目　生成順序
  Controlsプロパティに設定されている順序です
  但し、ここは自動に設定されるので、０を設定しておいてください。

  これ以降の項目はファイルから入出力するときに必要な項目です。

  第３項目　フィールド名
  テーブルのフィールド名です。読込むときと書き込むときに使用します

  第４項目　編集パターン
  フィールドの内容を表示するのに使用します。
  ここにカンマを使用する場合は必ずダブルクォーテーションで括ってください

  第５項目　フォールドのタイプです
  CnsOraNum:数値
  CnsOraChar:文字列
  CnsOraDate:日付
  CnsOraDateTime:日付時刻
  CnsOraBool:論理（実際は数値０，１）

  第６項目　キー項目
  ここに、「Skip」と入れるとキー項目として扱います。
  具体的にはUPDATE文のSQLを作成するときにWHERE句以降に記述する対象となります。


NextEnter

  リファレンス
  TScrollBoxEx.NextEnter
  TScrollBoxEx

  NextEnterプロパティは子コンポーネントでエンターキーが押された場合
  NameTablesプロパティの記述に従って次のコンポーネントにフォーカスをセットするか否かを指定できます。

  property NextEnter: Boolean;

  説明
  NextEnterプロパティが真の場合はエンターキーが押された場合
  OnKeyDownイベントを発生させたあとキー情報に変更がなければ
  NameTablesプロパティに登録されている順にフォーカスを移動させる。


NextStop

  リファレンス
  TScrollBoxEx.NextStop
  TScrollBoxEx

  NextStopプロパティは，次の項目にキーで移動させたくないコンポーネントを設定することができます。

  property　NextStop: ;

  説明
  NextStopプロパティは，エンターキーやTABキーなど次の項目に移すキーが押されても次の項目にフォーカスを
  移動させない元のコンポーネントを定義します。つまり、キーでの移動は一方通行になります。


NextTab

  リファレンス
  TScrollBoxEx.NextTab
  TScrollBoxEx

  NextTabプロパティは子コンポーネントでTABキーが押された場合
  NameTablesプロパティの記述に従って次のコンポーネントにフォーカスをセット
  子コンポーネントでShift+TABキーが押された場合
  NameTablesプロパティの記述に従って前のコンポーネントにフォーカスをセットするか否かを指定できます。

  property NextTab: Boolean;

  説明
  NextTabプロパティが真の場合はTABキーまたはShift+TABキーが押された場合
  OnKeyDownイベントを発生させたあとキー情報に変更がなければ
  NameTablesプロパティに登録されている順にフォーカスを移動させる。


PriorKeyCode

  リファレンス
  TScrollBoxEx.PriorKeyCode
  TScrollBoxEx

  PriorKeyCodeプロパティは子コンポーネントでキーが押された場合、NameTablesプロパティの記述に従って
  前のコンポーネントにフォーカスをセットするキーのコードを指定できます。

  property PriorKeyCode: Word;

  説明
  PriorKeyCodeプロパティは子コンポーネントでキーが押された場合、それが指定したコードと同じなら
  OnKeyDownイベントを発生させたあとキー情報に変更がなければ
  NameTablesプロパティに登録されている順に１つ前にフォーカスを移動させる。
  なお、０が指定されている場合は処理しない。

  例
  NameTablesの内容
  Edit1,0
  Edit2,1
  Edit3,2
  Edit4,3

  PriorKeyCode=VK_HOME(36)


PriorName

  リファレンス
  TScrollBoxEx.PriorName
  TScrollBoxEx

  PriorNameプロパティは，このScrollBoxExコンポーネントの先頭項目の前にフォーカスを
  移すコンポーネントを設定することができます。

  property　PriorName: ;

  説明
  PriorNameプロパティは，最上行(ItemIndexプロパティ=0)の先頭項目で前の項目に移すときにフォーカスを
  移動する先のコンポーネントを定義します。

  例

  NameTablesの内容
  Edit2,0
  Edit3,1
  Edit4,2

  PriorName=Edit1


PriorStop

リファレンス
  TScrollBoxEx.PriorStop
  TScrollBoxEx

  PriorStopプロパティは，前の項目にキーで移動させたくないコンポーネントを設定することができます。

  property　PriorStop: ;

  説明
  PriorStopプロパティは，↑キーやShift+TABキーなど前の項目に移すキーが押されても前の項目にフォーカスを
  移動させない元のコンポーネントを定義します。つまり、キーでの移動は一方通行になります。


PriorUp

  リファレンス
  TScrollBoxEx.PriorUp
  TScrollBoxEx

  PriorUpプロパティは子コンポーネントで↑キーが押された場合
  NameTablesプロパティの記述に従って前のコンポーネントにフォーカスをセットするか否かを指定できます。

  property PriorUp: Boolean;

  説明
  PriorUpプロパティが真の場合は↑キーが押された場合
  OnKeyDownイベントを発生させたあとキー情報に変更がなければ
  NameTablesプロパティに登録されている順に１つ前にフォーカスを移動させる。


SKipReadOnly

  リファレンス
  TScrollBoxEx.SKipReadOnly
  TScrollBoxEx

  SKipReadOnlyプロパティはキーでフォーカスを移す先のコンポーネントがEditコンポーネントやNumEditコンポーネントで
  そのコンポーネントのReadOnlyプロパティ=Trueが定義されていた場合
  NameTablesプロパティの記述に従って次または前のコンポーネントにフォーカスをセットせずに
  次の次のまたは前の前のコンポーネントに移動するか否かを設定できます。

  property SkipReadOnly: Boolean;

  説明
  SkipReadOnlyプロパティが真の場合はエンターキーや↑キーなどが押された場合
  フォーカスを移す先のコンポーネントがEditコンポーネントやNumEditコンポーネントでそのコンポーネントの
  ReadOnlyプロパティ=Trueが定義されていた場合
  NameTablesプロパティに登録されている順に１つスキップさせてフォーカスを移動させる。


TableOut

  リファレンス
  TScrollBoxEx.TableOut
  TScrollBoxEx

  TableOutプロパティはなんの情報も設定できません。

  property TableOut: Boolean;

  説明
  このプロパティを変化(False→True,True→False)させるとこのScrollBoxExコンポーネントの上に
  存在する子コンポーネントをDelphiの定義形式にてクリップボードに書き出します。

  例

   ScrDtlTbl : array [0..3] of Scr_Details_Inf = (
   ( FNm:'Edit2'; ActP: 0; Act: 0 ), // 1
   ( FNm:'Edit3'; ActP: 0; Act: 0 ), // 2
   ( FNm:'Edit4'; ActP: 0; Act: 0 ), // 3
   ( FNm:'Edit1'; ActP: 0; Act: 0 ) // 4
   );


UseBrushColor

  リファレンス
  TScrollBoxEx.UseBrushColor
  TScrollBoxEx

  UseBrushColor プロパティは、UseNameプロパティに定義されているコンポーネントの
  表示明細エリアの背景の色指定コードを指定することができます。

  property UseBrushColor: ;

  説明
  UseBrushColor プロパティは、UseNameプロパティに定義されているコンポーネントの
  表示明細エリアの背景の色を指定したもので表示することができます。
  また、１行置きに違えたい場合はUseShimaFlgプロパティおよびUseShimaColorプロパティを
  設定してください。

  使用方法および例


UseName

リファレンス
  TScrollBoxEx.UseName
  TScrollBoxEx

  UseNameプロパティは，指定したコンポーネントの背景色がUseBrushColorプロパティになります

  property　UseName: ;

  説明
  UseNameプロパティは，背景色がUseBrushColorプロパティになるコンポーネントを定義します。
  また、１行置きに違えたい場合はUseShimaFlgプロパティおよびUseShimaColorプロパティを
  設定してください。

  使用方法および例


UseShimaColor

  リファレンス
  TScrollBoxEx.UseShimaColor
  TScrollBoxEx

  UseShimaColor プロパティは、UseNameプロパティに定義されているコンポーネントの
  ItemIndexプロパティが偶数の表示明細エリアの背景の色指定コードを指定することができます。

  property UseBrushColor: ;

  説明
  UseShimaColor プロパティは、UseShimaFlgプロパティが真の場合、UseNameプロパティに定義されている
  コンポーネントのItemIndexプロパティが偶数の表示明細エリアの背景の色を指定したもので表示することができます。
  なお、この場合、UseBrushColorプロパティは奇数のの表示明細エリアの背景の色となります。

  例

  UseName=Label1
  UseShimaFlg=True
  UseShimaColor=clAqua
  UseBrushColor=clWhite
  Label1.Color=clActiveCaption


UseShimaFlg

  リファレンス
  TScrollBoxEx.UseShimaFlg
  TScrollBoxEx

  UseShimaFlgプロパティは表示明細の子コンポーネントの背景色を１行置きに変化させるか否かを指定できます。

  property UseShimaFlg: Boolean;

  説明
  UseShimaFlgプロパティを真にするとItemIndexプロパティが偶数の表示明細のUseNameプロパティで定義した
  コンポーネントの背景色をUseShimaColorプロパティの色指定コードにする。

  使用方法および例


NextName

  リファレンス
  TScrollBoxEx.NextName
  TScrollBoxEx

  NextNameプロパティは，このScrollBoxExコンポーネントの最終項目の次にフォーカスを
  移すコンポーネントを設定することができます。

  property　NextName: ;

  説明
  NextNameプロパティは，最下行(ItemIndexプロパティ=ItemMaxプロパティ-1)の最終項目で次の項目に移すときにフォーカスを
  移動する先のコンポーネントを定義します。

  例

  NameTablesの内容
  Edit1,0
  Edit2,1
  Edit3,2

  NextName=Edit4


CompoName1

  リファレンス
  TTextMarge.CompoName1
  TTextMarge

  CompoName1プロパティは,前につなげるコンポーネントを指定できます。

  property CompoName1: ;

  説明
  TControlから派生しているコンポーネントならばなんでも
  指定できますが、文字列をつなげる処理を行うものは
  NumEditまたはEditコンポーネントのみとなり
  他のコンポーネントでつなげる場合は
  OnSetTextおよびOnGetTextイベントを指定してください。


CompoName2

  リファレンス
  TTextMarge.CompoName2
  TTextMarge

  CompoName2プロパティは,後につなげるコンポーネントを指定できます。

  property CompoName2: ;

  説明
  TControlから派生しているコンポーネントならばなんでも
  指定できますが、文字列をつなげる処理を行うものは
  NumEditまたはEditコンポーネントのみとなり
  他のコンポーネントでつなげる場合は
  OnSetTextおよびOnGetTextイベントを指定してください。


Text

  リファレンス
  TTextMarge.Text
  TTextMarge

  Textプロパティは,文字列を取得したり、設定することができます。

  property Text: String;

  説明
  ここの内容を取得すると定義されたコンポーネントの文字列をつなぎ合わせます。
  また、設定すると定義されたコンポーネントに分割して文字列をセットします。


  メソッドリファレンス

  シーエス作成コンポーネント　Copyright(C)シーエス


Assign

リファレンス
  TCBColumn.Assign
  TCBColumn

  Assign メソッドは，ソース列の内容を新しい列にコピーします。

  procedure Assign(Source: TPersistent); override;

  説明
  Assign メソッドは，ソースオブジェクトと同じ Alignment，Color，Font，ParentColor，ParentFont，TagString，および Width の値を使って新しい列を作成します。


Create

リファレンス
  TCBColumn.Create
  TCBColumn

  Create メソッドは，ドロップダウンリスト列を作成し，初期化します。

  constructor Create(Collection: TCollection); override;

  説明
  Create メソッドを呼び出すと，TCBColumn オブジェクトをインスタンス化できます。
  Create メソッドは TCBColumns インスタンスを引数にとる必要があります。
  Create は，ドロップダウンリスト列およびその背景色（TColor）とフォント（TFont）等を作成します。


Destroy

リファレンス
  TCBColumn.Destroy
  TCBColumn

  Destroy メソッドは，列を破棄して，割り当てていたメモリを解放します。

  destructor Destroy; override;

  説明
  Destroy メソッドは，TCBColumn インスタンスとともにその背景色（TColor），フォント（TFont）等を破棄します。


Create

  リファレンス
  TCSPrint.Create
  TCSPrint

  Createメソッドは,TCSPrintインスタンスを作成します。

  constructor Create( AOwner: TComponent ); override;

  説明
  Create メソッドを呼び出すと，実行時に TCSPrintのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TCSPrint.Destroy
  TCSPrint

  Destroyメソッドは,TCSPrintインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


PrintInit

  リファレンス
  TCSPrint.PrintInit
  TCSPrint

  PrintInitメソッドは,設定された情報を元にプリンタデバイスを設定します。

  function PrintInit: boolean;

  説明
  PaperMode,PaperTray,PColor,PName,POri,PQuality,PSize,PSizeX,PSizeY,FormNameプロパティの
  情報を元にプリンタデバイスを設定し、MaxColumn,MaxLine,PResolvX,PResolvYプロパティに
  情報をセットします。なお、ScrMaxプロパティが真の場合、この時点でフォームの大きさを設定します。

  戻り値
  真の場合、正常に設定しました。偽の場合、プリンタデバイスの設定に失敗しました。


Abort

  リファレンス
  TCSPrint.Abort
  TCSPrint

  Abortメソッドは,処理を中断します。

  procedure Abort;

  説明
  印刷データを破棄し、処理を中断します。


BackPaint

  リファレンス
  TCSPrint.BackPaint
  TCSPrint

  BackPaintメソッドは,背景を印刷します。

  procedure BackPaint( Prnt_Inf : Prn_Line_Inf );

  説明
  BackBmp,BackColor,BackColorSプロパティの情報と罫線印字情報の
  開始行、列、位置、終了行、列、位置を使用して背景を印刷します。


BeginDoc

  リファレンス
  TCSPrint.BeginDoc
  TCSPrint

  BeginDocメソッドは,印刷開始する宣言です。

  procedure BeginDoc;

  説明
  BeginDocメソッドは、頁番号の初期化と印刷フォントの初期化をしています。


DetailPrint

  リファレンス
  TCSPrint.DetailPrint
  TCSPrint

  DetailPrintメソッドは,明細を印刷します。

  procedure DetailPrint(AddGyo: Integer; Value: array of Prn_Level2_Inf); overload;
  procedure DetailPrint(AddGyo: Integer; Value: array of Prn_Details_Inf); overload;

  説明
  各印字情報の内容に沿って印刷する。AddGyoを加算した行位置で印刷する。


DetailPrintO

  リファレンス
  TCSPrint.DetailPrintO
  TCSPrint

  DetailPrintOメソッドは,明細を印刷します。

  procedure DetailPrintO(AddGyo: Integer; Value: array of Prn_Details_Inf);

  説明
  明細印字情報の内容に沿って印刷する。AddGyoを加算した行位置で印刷する。


EndDoc

  リファレンス
  TCSPrint.EndDoc
  TCSPrint

  EndDocメソッドは,印刷を開始するか、プレビュー表示します。

  procedure EndDoc;

  説明
  溜まっている印字データを元に印刷を開始するか、プレビュー表示します。


HeaderPrint

  リファレンス
  TCSPrint.HeaderPrint
  TCSPrint

  HeaderPrintメソッドは,ヘッダを印刷します。

  procedure HeaderPrint(Value: array of Prn_Level2_Inf); overload;
  procedure HeaderPrint(Value: array of Prn_Header_Inf); overload;

  説明
  各印字情報の内容に沿って印刷する。


HeaderPrintO

  リファレンス
  TCSPrint.HeaderPrintO
  TCSPrint

  HeaderPrintOメソッドは,ヘッダを印刷します。

  procedure HeaderPrintO(Value: array of Prn_Header_Inf);

  説明
  ヘッダ印字情報の内容に沿って印刷する。


Level2Print

  リファレンス
  TCSPrint.Level2Print
  TCSPrint

  Level2Printメソッドは,新印字情報に沿って印刷します。

  procedure Level2Print(AddGyo: Integer; Value: array of Prn_Level2_Inf; ArgDataSet: TDataSet; ArgAction: TActionEvent = nil);

  説明
  ヘッダや明細だけでは、印刷できないものを印刷するときに使用します。


LinePrint

  リファレンス
  TCSPrint.LinePrint
  TCSPrint

  LinePrintメソッドは,罫線を印刷します。

  procedure LinePrint(Value: array of Prn_Line_Inf);

  説明
  罫線印字情報に沿って罫線を印字します。


NewPage

  リファレンス
  TCSPrint.NewPage
  TCSPrint

  NewPageメソッドは,改頁します。

  procedure NewPage;

  説明
  改頁をしてフォントを初期化します。


PrintBitmap

  リファレンス
  TCSPrint.PrintBitmap
  TCSPrint

  PrintBitmapメソッドは,ビットマップデータを等倍で印刷します。

  procedure PrintBitmap( Gyo, Retu : Currency; ArgBitmap : TBitmap; BName : string = '' );

  説明
  ビットマップを等倍で印字します。拡大、縮小はしていないので
  プリンタによって、大きさが変化する可能性があります。


PrintBitmap2

  リファレンス
  TCSPrint.PrintBitmap2
  TCSPrint

  PrintBitmapメソッドは,ビットマップデータを拡大縮小して印刷します。

  procedure PrintBitmap2( Gyo, Retu, HGyo, WRetu : Currency; ArgBitmap : TBitmap; BName : string = '' );

  説明
  ピットマップデータを高さ（行数で指定）、幅（列数で指定）にあわせて拡大縮小して
  印刷します。


PrintBox

  リファレンス
  TCSPrint.PrintBox
  TCSPrint

  PrintBoxメソッドは,ボックス型に罫線を印刷します。

  procedure PrintBox( StX, StY, EndX, EndY, W : Integer; C : TColor; Style : TPenStyle; R : Integer );

  説明
  このメソッドは内部で使用しているものです。
  ピクセル単位で指定しているため、アプリケーションでは、使用しないでください。


PrintL

  リファレンス
  TCSPrint.PrintL
  TCSPrint

  PrintLメソッドは,罫線を印刷します。

  procedure PrintL( Prnt_Inf : Prn_Line_Inf );

  説明
  罫線印字情報に沿って罫線を１つ印刷します。


PrintLine

  リファレンス
  TCSPrint.PrintLine
  TCSPrint

  PrintLineメソッドは,罫線を印刷します。

  procedure PrintLine( StX, StY, EndX, EndY, W : Integer; C : TColor; Style : TPenStyle );

  説明
  このメソッドは内部で使用しているものです。
  ピクセル単位で指定しているため、アプリケーションでは、使用しないでください。


PrintP

  リファレンス
  TCSPrint.PrintP
  TCSPrint

  PrintPメソッドは,ペイント印刷します。

  procedure PrintP( Prnt_Inf : Prn_Line_Inf );

  説明
  PaintColor,PaintColorSプロパティの情報と罫線印字情報の
  開始行、列、位置、終了行、列、位置を使用してペイント印刷します。
  なお、PaintColorが02FeFeFeの場合のみ、プリンタの解像度にあわせて
  印刷イメージを内部で変更しています。


PrintPageText

  リファレンス
  TCSPrint.PrintPageText
  TCSPrint

  PrintPageTextメソッドは,該当する頁に文字列を印刷します。

  procedure PrintPageText( Page : Integer; Gyo, Retu : Currency; PrnText : String; Point : Integer = 0);

  説明
  合計頁数や構成率など、最後まで集計した結果はじめて、得られるものを
  印刷するときに使用します。

  例

  for I := 1 to GOUKEIPAGE do
   PrintPageText( I, 1, 150, '/' + IntToStr(GOUKEIPAGE));


PrintTerm

  リファレンス
  TCSPrint.PrintTerm
  TCSPrint

  PrintTermメソッドは,印刷データを破棄します。

  procedure PrintTerm;

  説明
  内部に保存されている印刷データを破棄します。
  印刷を実行されても、印刷データは残っているので
  いらなければ、破棄したほうがよい。


PrintText

  リファレンス
  TCSPrint.PrintText
  TCSPrint

  PrintTextメソッドは,文字列を印刷します。

  procedure PrintText( Gyo, Retu : Currency; PrnText : String; Point : Integer = 0);

  説明
  サイズ以外のフォントの変更等ができないので、通常は、印字情報を使った印刷を
  使用してください。


Reprint

  リファレンス
  TCSPrint.Reprint
  TCSPrint

  Reprintメソッドは,印刷データを再度印刷またはプレビュー表示します。

  procedure Reprint;

  説明
  PrintTermメソッドで印字データを破棄しないかぎり、印字データは
  溜まったままになっているのでReprintメソッドを発行して
  同一内容を再印刷することができます。


Create

  リファレンス
  TCalButton.Create
  TCalButton

  Createメソッドは,TCalButtonのインスタンスを作成します。

  constructor Create(AOwner: TComponent); override;

  説明
  Create メソッドを呼び出すと，実行時に TCalButtonのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TCalButton.Destroy
  TCalButton

  Destroyメソッドは,TCalButtonのインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


Click

  リファレンス
  TCalButton.Click
  TCalButton

  Click メソッドは，OnClick イベントを発生させるか，または関連付けられたアクションを呼び出します。

  procedure Click; override;

  説明
  Click メソッドを呼び出すと，OnClick イベントを発生することができます。
  ボタンに OnClick イベントハンドラがある場合や，
  ボタンにアクションが関連付けられている場合，Click メソッドはアプリケーションに
  そのボタンをクリックしたときと同じ動作をさせることができます。


Create

  リファレンス
  TEGColumn.Create
  TEGColumn

  Createメソッドは,TEGColumnのインスタンスを作成します。

  constructor Create( Collection: TCollection); override;

  説明
  Create メソッドを呼び出すと，実行時に TEGColumnのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TEGColumn.Destroy
  TEGColumn

  Destroyメソッドは,TEditGridのインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


Assign

  リファレンス
  TEGColumn.Assign
  TEGColumn

  Assignメソッドは,ほかの類似オブジェクトの内容をコピーします。

  procedure Assign( Source: TPersistent); override;

  説明
  Assign メソッドを呼び出すと，プロパティをコピーしたり，オブジェクトの属性をほかのオブジェクトからコピーしたりできます。
  Assign メソッドを呼び出す標準形式は次のとおりです。

  Destination.Assign(Source);

  これは，Destination オブジェクトに Source オブジェクトの内容をコピーするように通知します。
  ほとんどのオブジェクトは，Assign メソッドをオーバーライドして，
  ほかの類似オブジェクトからのプロパティの代入を処理します。
  Assign メソッドをオーバーライドするときに Destination オブジェクトが
  Source パラメータのクラスからのプロパティの代入を処理できない場合は継承メソッドを呼び出します。
  オーバーライドした Assign メソッドが Source からのプロパティの代入を処理できない場合，
  TPersistent に実装された .Assign メソッドは，
  その Source オブジェクトの AssignTo メソッドを呼び出します。
  これによって，Source オブジェクトが代入を処理できるようになります。
  Source オブジェクトが nil の場合，TPersistent.Assign は EConvertError 例外を生成します。

  一般的に，Destination := Source 文は Destination.Assign(Source) と同じではありません。
  Destination := Source 文は Destination の参照先を Source と同じオブジェクトにします。
  一方，Destination.Assign(Source) 文は Source で参照するオブジェクトの内容を
  Destination で参照するオブジェクトにコピーします。

  注意　いくつかのプロパティの型もオブジェクトです。これらのプロパティが
        Assign メソッドを使ってプロパティの値を設定する書き込みメソッドを持っている場合，
        Destination := Source 文は Destination.Assign(Source) と同じになります。


Create

  リファレンス
  TEditGrid.Create
  TEditGrid

  Createメソッドは,TEditGridのインスタンスを作成します。

  constructor Create( AOwner: TComponent); override;

  説明
  Create メソッドを呼び出すと，実行時に TEditGridのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TEditGrid.Destroy
  TEditGrid

  Destroyメソッドは,TEditGridのインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


DoEnter

  リファレンス
  TEditGrid.DoEnter
  TEditGrid

  DoEnterメソッドは,コントロールにフォーカスが移動してきた場合の処理をします。

  procedure DoEnter; override;

  説明
  アプリケーションで直接 DoExitメソッドを呼び出さないでください。


DoExit

  リファレンス
  TEditGrid.DoExit
  TEditGrid

  DoExitメソッドは,コントロールからフォーカスが移動した場合の処理をします。

  procedure DoExit; override;

  説明
  アプリケーションで直接 DoExitメソッドを呼び出さないでください。


CanEditShow

  リファレンス
  TEditGrid.CanEditShow
  TEditGrid

  CanEditShowメソッドは,グリッドを編集するインプレース編集コントロールを作成できるかどうかを示します。

  function CanEditShow : Boolean; override;

  説明
  アプリケーションで直接 CanEditShow メソッドを呼び出さないでください。


CreateEditor

  リファレンス
  TEditGrid.CreateEditor
  TEditGrid

  CreateEditorメソッドは,インプレースエディタコントロールを作成します。

  function CreateEditor: TInplaceEdit; override;

  説明
  アプリケーションで直接 CreateEditorメソッドを呼び出さないでください。


KeyDown

  リファレンス
  TEditGrid.KeyDown
  TEditGrid

  KeyDownメソッドは,キーが押されたときの特定の処理を指定します。

  procedure KeyDown(var Key: Word; Shift: TShiftState); override;

  説明
  アプリケーションで直接 KeyDownメソッドを呼び出さないでください。


KeyPress

  リファレンス
  TEditGrid.KeyPress
  TEditGrid

  KeyPressメソッドは,キーが押されたときの特別の処理を指定します。

  procedure KeyPress(var Key: Char); override;

  説明
  アプリケーションで直接 KeyPressメソッドを呼び出さないでください。


DrawCell

  リファレンス
  TEditGrid.DrawCell
  TEditGrid

  DrawCellメソッドは,セルの内容を描画するメソッドの抽象プロトタイプを提供します。

  procedure DrawCell(ACol, ARow: Longint; ARect: TRect; AState: TGridDrawState); override;

  説明
  アプリケーションで直接 DrawCellメソッドを呼び出さないでください。


SizeChanged

  リファレンス
  TEditGrid.SizeChanged
  TEditGrid

  SizeChangedメソッドは,グリッドのサイズ変更に応答します。

  procedure SizeChanged(OldColCount, OldRowCount: Longint); override;

  説明
  アプリケーションで直接 SizeChangedメソッドを呼び出さないでください。


PriorSetFocus

  リファレンス
  TEditGrid.PriorSetFocus
  TEditGrid

  PriorSetFocusメソッドは,PriorNameプロパティに設定されたコンポーネントにフォーカスを移します。

  procedure PriorSetFocus;

  説明
  PriorNameプロパティがnil以外ならば、そこに指定されたコンポーネントにフォーカスを移します。


NextSetFocus

  リファレンス
  TEditGrid.NextSetFocus
  TEditGrid

  NextSetFocusメソッドは,NextNameプロパティに設定されたコンポーネントにフォーカスを移します。

  procedure NextSetFocus;

  説明
  NextNameプロパティがnil以外ならば、そこに指定されたコンポーネントにフォーカスを移します。


FirstSetFocus

  リファレンス
  TEditGrid.FirstSetFocus
  TEditGrid

  FirstSetFocusメソッドは,最初の編集できるセルに移動します。

  procedure FirstSetFocus( GFlg : Boolean = True );

  説明
  GFlgがTrueの場合は１行目の最初の編集できるセルに移動します。
  GFlgがFalseの場合はRowプロパティが示す行のセルの最初の編集できるセルに移動します。


LastSetFocus

  リファレンス
  TEditGrid.LastSetFocus
  TEditGrid

  LastSetFocusメソッドは,最後の編集できるセルに移動します。

  procedure LastSetFocus( GFlg : Boolean = True );

  説明
  GFlgがTrueの場合は１行目の最後の編集できるセルに移動します。
  GFlgがFalseの場合はRowプロパティが示す行のセルの最後の編集できるセルに移動します。


Create

  リファレンス
  TKanaEdit.Create
  TKanaEdit

  Createメソッドは,TKanaEditのインスタンスを作成します。

  constructor Create( AOwner: TComponent); override;

  説明
  Create メソッドを呼び出すと，実行時に TKanaEditのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TKanaEdit.Destroy
  TKanaEdit

  Destroyメソッドは,TKanaEditのインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


HuriganaSet

  リファレンス
  TKanaEdit.HuriganaSet
  TKanaEdit

  HuriganaSetメソッドは,ふりがなをTextにセットします。

  procedure HuriganaSet;

  説明
  アプリケーションでなるべく HuriganaSet メソッドを呼び出さないでください。


HuriganaInit

  リファレンス
  TKanaEdit.HuriganaInit
  TKanaEdit

  HuriganaInitメソッドは,内部情報を初期化します。

  procedure HuriganaInit;

  説明
  アプリケーションでなるべく HuriganaInit メソッドを呼び出さないでください。


Create

リファレンス
  TMCCBoxEx.Create
  TMCCBoxEx

  Create メソッドは，TMCCBoxEx インスタンスを作成および初期化します。

  constructor Create(AOwner: TComponent); override;

  説明
  Create を呼び出すと，実行時にコンボボックスを生成できます。設計時にフォームに配置されたコンボボックスは自動的に作成されます。
  AOwner は，コンボボックスインスタンスを解放する権限を持つコンポーネント（通常はフォーム）です。


ChangeIndex

リファレンス
  TMCCBoxEx.ChangeIndex
  TMCCBoxEx

  ChangeIndexメソッドは，InputNameプロパティに指定されているコンポーネントに選択行の内容をセットします。

  procedure ChangeIndex;

  ChangeIndexメソッドは，InputNameプロパティに指定されているコンポーネントに選択された行のItemsプロパティの
  TargetInputプロパティの列の内容をセットします。

  セットできるコンポーネントとプロパティ

  TEdit.Text
  TNumEdit.Text
  TStaticText.Caption
  TLabel.Caption
  TTextMarge.Text


ChangeItem

リファレンス
  TMCCBoxEx.ChangeItem
  TMCCBoxEx

  ChangeItemメソッドは，InputNameプロパティに指定されているコンポーネントの内容と同一の行をItemIndexプロパティにセットします。

  function ChangeItem : Boolean;

  ChangeItemメソッドは，InputNameプロパティに指定されているコンポーネントの内容とItemsプロパティの
  TargetInputプロパティの列の内容を比較して同一ならその行を選択します。
  選択できた場合はTrueをできなかった場合はFalseを返します。

  取得できるコンポーネントとプロパティ

  TEdit.Text
  TNumEdit.Text
  TStaticText.Caption
  TLabel.Caption
  TTextMarge.Text


Destroy

リファレンス
  TMCCBoxEx.Destroy
  TMCCBoxEx

  Destroy メソッドは，コンボボックスを破棄し，割り当てていたメモリを解放します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。かわりに Free メソッドを呼び出すようにします。
  Free は，コンボボックスが nil でないことを確認してからのみ Destroy を呼び出します。


SearchIndex

リファレンス
  TMCCBoxEx.SearchIndex
  TMCCBoxEx

  SearchIndexメソッドは，InputNameプロパティに指定されているコンポーネントにTextプロパティと同一のItemIndexプロパティを
  検索後、内容をセットします。

  function SearchIndex : Boolean;

  SearchIndexメソッドは，TextプロパティとItemsプロパティのTargetColumnプロパティの列の内容を
  比較して同一ならその行を選択します。その後InputNameプロパティに指定されているコンポーネントに
  選択された行のItemsプロパティのTargetInputプロパティの列の内容をセットします。
  選択できた場合はTrueをできなかった場合はFalseを返します。

  セットできるコンポーネントとプロパティ

  TEdit.Text
  TNumEdit.Text
  TStaticText.Caption
  TLabel.Caption
  TTextMarge.Text


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:17 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:17 -0000 vti_filesize:IR|266 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|TMCCBoxEx vti_title:SR|TMCCBoxEx vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:18 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:18 -0000 vti_filesize:IR|1012 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedtitle:SR|Create vti_title:SR|Create vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:19 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:19 -0000 vti_filesize:IR|1111 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedtitle:SR|ChangeIndex vti_title:SR|ChangeIndex vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:20 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:20 -0000 vti_filesize:IR|1209 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedtitle:SR|ChangeItem vti_title:SR|ChangeItem vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:21 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:21 -0000 vti_filesize:IR|972 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedtitle:SR|Destroy vti_title:SR|Destroy vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|15 Oct 2003 03:02:23 -0000 vti_extenderversion:SR|4.0.2.5526 vti_cacheddtm:TX|15 Oct 2003 03:02:23 -0000 vti_filesize:IR|1341 vti_cachedlinkinfo:VX|H|..\\\\..\\\\SD00000020.htm H|..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\SD00000020.htm NHUS|file:///D:/HELP/HTML/メソッドリファレンス/TMCCBoxEx/..\\\\..\\\\社内コンポーネント\\\\SD00000119.htm vti_cachedtitle:SR|SearchIndex vti_title:SR|SearchIndex vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_backlinkinfo:VX|


Create

リファレンス
  TNumEdit.Create
  TNumEdit

  Create メソッドは，新しい TNumEdit オブジェクトを作成および初期化します。

  constructor Create(AOwner: TComponent);

  説明
  Create メソッドを呼び出すと，新しいNumEdit オブジェクトを作成および初期化できます。
  AOwner はスクロールボックスの解放を処理するコンポーネント（通常はフォーム）です。


Destroy

リファレンス
  TNumEdit.Destroy
  TNumEdit

  Destroy メソッドは，メモリから TNumEdit オブジェクトを削除します。

  destructor Destroy; override;

  説明
  Destroy メソッドを呼び出さないでください。かわりに，Free メソッドを呼び出してください。NumEdit オブジェクトが
  nil でない場合，Free メソッドは Destroy メソッドを呼び出します。


Clear

リファレンス
  TNumEdit.Clear
  TNumEdit

  Clear メソッドは，編集コントロールからテキストをすべて削除します。

  procedure Clear; virtual;

  説明
  Clear メソッドは Text プロパティを空の文字列と置き換えます。
  Clear は選択されたテキストだけでなく，すべてのテキストを削除します。
  選択されているテキストのみを削除するには ClearSelection を使います。


ClearSelect

リファレンス
  TNumEdit.ClearSelect
  TNumEdit

  ClearSelect メソッドは，選択されたテキストを選択クリアします。

  procedure ClearSelect;

  説明
  ClearSelect メソッドを呼び出すと，選択クリアします。
  テキストが選択されていなければ，ClearSelection は何もしません。


ClearSelection

リファレンス
  TNumEdit.ClearSelection
  TNumEdit

  ClearSelection メソッドは，選択されたテキストを編集コントロールから削除します。

  procedure ClearSelection;

  説明
  ClearSelection メソッドを呼び出すと，選択されたテキストを編集コントロールから削除できます。
  テキストが選択されていなければ，ClearSelection は何もしません。
  テキストすべてが選択されている場合，ClearSelection は Clear メソッドと同様にすべてのテキストを削除します。

  注意 　ClearSelection の呼び出しは編集コントロールに WM_CLEAR メッセージを送るのと同じ動作をします。


ClearUndo

リファレンス
  TNumEdit.ClearUndo
  TNumEdit

  ClearUndo メソッドは，処理を取り消して元に戻すためのバッファをクリアし，テキストの変更がこれ以上バックアップされないようにすます。

  procedure ClearUndo;

  説明
  ClearUndo メソッドを使うと，Text プロパティへの変更にコミットできます。
  ClearUndo を呼び出すと，CanUndo プロパティは False になり，Undo メソッドを呼び出しても無効になります。


CopyToClipboard

リファレンス
  TNumEdit.CopyToClipboard
  TNumEdit

  CopyToClipboard メソッドは，編集コントロールの選択されたテキストをクリップボードに CF_TEXT のフォーマットでコピーします。

  procedure CopyToClipboard;

  説明
  CopyToClipboard メソッドを呼び出すと，選択したテキストでクリップボードの内容を置き換えることができます。
  テキストが選択されていない場合，CopyToClipboard はクリップボードの内容を消去しません。
  テキストが選択されている場合，CopyToClipboard はクリップボードは何もしません。

  注意　 CopyToClipboard の呼び出しは編集コントロールに WM_COPY メッセージを送るのと同じ動作をします。


CutToClipboard

リファレンス
  TNumEdit.CutToClipboard
  TNumEdit

  CutToClipboard メソッドは，選択されたテキストを CF_TEXT フォーマットでクリップボードにコピーしてから選択範囲を削除します。

  procedure CutToClipboard;

  説明
  CutToClipboard メソッドは，選択されているテキストでクリップボードの内容を置き換え，選択したテキストを消去します。
  テキストが選択されていない場合，CutToClipboard は何もしません。


PasteFromClipboard

リファレンス
  TNumEdit.PasteFromClipboard
  TNumEdit

  PasteFromClipboard メソッドは，クリップボードの内容を編集コントロールにコピーして，現在の選択範囲を置き換えます。

  procedure PasteFromClipboard;

  説明
  PasteFromClipboard メソッドは，選択されているテキストをクリップボードの内容で置き換えるか，テキストが選択されていなければ，クリップボードの内容をカーソル位置に挿入します。
  クリップボードが空の場合，またはクリップボードに CF_TEXT のフォーマットのデータがない場合は，PasteFromClipboard は何もしません。

  注意　 PasteFromClipboard の呼び出しは，編集コントロールに WM_PASTE メッセージを送るのと同じ動作をします。


SelectAll

リファレンス
  TNumEdit.SelectAll
  TNumEdit

  SelectAll メソッドは，編集コントロール中のテキストをすべて選択します。

  procedure SelectAll;

  説明
  SelectAll メソッドは編集コントロールのテキストをすべて選択します。
  一部のテキストのみを選択するには SelStart および SelLength プロパティを使います。


Undo

リファレンス
  TNumEdit.Undo
  TNumEdit

  Undo メソッドは，取り消しバッファにあるすべての変更内容を取り消します。

  procedure Undo;

  説明
  Undo メソッドを呼び出すと，最後に ClearUndo メソッドが呼び出されてから Text プロパティに対して加えられた変更を取り消すことができます。
  一度も ClearUndo メソッドを呼び出していない場合，Undo メソッドはそれまでのすべての変更を取り消します。
  取り消しバッファに変更があるかどうかを確認するには，CanUndo プロパティを調べてください。


ItemsTo

  リファレンス
  TScrollBoxEx.ItemsTo
  TScrollBoxEx

  ItemsToメソッドはItemsプロパティを子コンポーネントの表示データにセットします

  procedure ItemsTo(Index: Integer);

  説明
  ItemsToメソッドを呼び出すとItemsプロパティを子コンポーネントの表示データにセットします。

  表示データ
   コンポーネントのTextプロパティにそのままセット
   コンポーネントのLinesプロパティのCommaTextプロパティにそのままセット
   コンポーネントのCaptionプロパティにItemLabelプロパティ=Falseの場合で=ColorLabelプロパティ
  でない場合にセット
   コンポーネントのCaptionプロパティにそのままセット
  NumEditコンポーネントのTextプロパティに数字文字列化したものをセット
  TextMargeコンポーネントのTextプロパティにそのままセット
   コンポーネントのCheckedプロパティに先頭１バイトが"0","F","f"ならば=Falseをそれ以外ならば=Trueをセット
   コンポーネントのCheckedプロパティに先頭１バイトが"0","F","f"ならば=Falseをそれ以外ならば=Trueをセット
   コンポーネントのSelected[?]プロパティをすべてクリアしたあと１度StringListオブジェクトのCommaTextプロパティ
  にセットしTStringList.Strings[?]と同一の行を探し出しその行のSelectedプロパティにTrueをセットする
   コンポーネントのTextプロパティにそのままセット
  MultiColComboBoxコンポーネントのTextプロパティにそのままセット
  MCCBoxExコンポーネントのTextプロパティにそのままセット


CompoTo

  リファレンス
  TScrollBoxEx.CompoTo
  TScrollBoxEx

  CompoToメソッドは子コンポーネントの表示データをItemsプロパティに書込みます

  procedure CompoTo(Index: Integer);

  説明
  CompoToメソッドを呼び出すと子コンポーネントの表示データをItemsプロパティに書込みます。

  表示データ
   コンポーネントのTextプロパティ
   コンポーネントのLinesプロパティのCommaTextプロパティ
   コンポーネントのCaptionプロパティ
   コンポーネントのCaptionプロパティ
  NumEditコンポーネントのValTextプロパティ
  TextMargeコンポーネントのTextプロパティ
   コンポーネントのCheckedプロパティ=Trueならば"TRUE",=Falseならば"FALSE"
   コンポーネントのCheckedプロパティ=Trueならば"TRUE",=Falseならば"FALSE"
   コンポーネントのSelected[?]プロパティ=TrueならばListBox.Items[?]をStringListオブジェクトに
  セットしStringListオブジェクトのCommaTextプロパティ
   コンポーネントのTextプロパティ
  MultiColComboBoxコンポーネントのTextプロパティ
  MCCBoxExコンポーネントのTextプロパティ


GetTableCompo

  リファレンス
  TScrollBoxEx.GetTableCompo
  TScrollBoxEx

  GetTableCompoメソッドは表示明細に対応する位置のコンポーネントを取得できる。

  function GetTableCompo(X, Y: Integer): TComponent;

  説明
  GetTableCompoメソッドを呼び出すと表示明細に対応する位置のコンポーネントを取得する。


GetItemIndexNo

  リファレンス
  TScrollBoxEx.GetItemIndexNo
  TScrollBoxEx

  GetItemIndexNoメソッドは指定した縦方向の位置情報をItemIndexプロパティで
  表した明細№を取得できる。

  function GetItemIndexNo(Y: Integer): Integer;

  説明
  GetItemIndexNoメソッドを呼び出すと指定した縦方向の位置情報をItemIndexプロパティで
  表した明細№を取得する。

  主にOnMouseUpイベントで使用する。

  例

  procedure TForm1.ScrollBoxEx1MouseUp(Sender: TObject; Button: TMouseButton;
    Shift: TShiftState; X, Y: Integer);
  var
    WrkIdx1, WrkIdx2 : Integer;
  begin
    WrkIdx1 := ScrollBoxEx1.ItemIndex;　　　　　　　　//現在の入力行№を取得
    WrkIdx2 := ScrollBoxEx1.GetItemIndexNo(Y);　　//クリックされた場所から移動先の行№を取得
    if (WrkIdx2 >= 0) and (WrkIdx2 < ScrollBoxEx1.ItemMax) then
    begin
      if WrkIdx1 <> WrkIdx2 then
      begin
        ScrollBoxEx1.CompoTo(WrkIdx1);　　　　　//子コンポーネントからItemsプロパティに
        ScrollBoxEx1.ItemsTo(WrkIdx2);　　　　　　//Itemsプロパティから子コンポーネント
        ScrollBoxEx1.ItemIndex := WrkIdx2;　　　　//入力行№の設定
      end;
    end;
  end;


FirstSetFocus

  リファレンス
  TScrollBoxEx.FirstSetFocus
  TScrollBoxEx

  FirstSetFocusメソッドは先頭項目にフォーカスを移します。

  procedure FirstSetFocus;

  説明
  FirstSetFocusメソッドを呼び出すとNameTablesプロパティの記述に従って最初に定義されたコンポーネントにフォーカスを移します。


LastSetFocus

  リファレンス
  TScrollBoxEx.LastSetFocus
  TScrollBoxEx

  LastSetFocusメソッドは最終項目にフォーカスを移します。

  procedure LastSetFocus;

  説明
  LastSetFocusメソッドを呼び出すとNameTablesプロパティの記述に従って最後に定義されたコンポーネントにフォーカスを移します。


PriorSetFocus

  リファレンス
  TScrollBoxEx.PriorSetFocus
  TScrollBoxEx

  PriorSetFocusメソッドはPriorNameプロパティに定義されたコンポーネントにフォーカスを移します。

  procedure PriorSetFocus;

  説明
  PriorSetFocusメソッドを呼び出すとPriorNameプロパティに定義されたコンポーネントにフォーカスを移します。
  PriorNameプロパティに定義されたコンポーネントの上位コンポーネントがTabSheetコンポーネントでさらに
  その上位コンポーネントがPageControlコンポーネントの場合、フォーカスを移す前に対応するページに切替えます。
  なお、PriorNameプロパティに定義されたコンポーネントがScrollBoxExコンポーネントだった場合
  LastSetFocusメソッドが動作します。

  例

  ScrollBoxEx1.NextName=ScrollBoxEx2
  ScrollBoxEx2.PriorName=ScrollBoxEx1
  ScrollBoxEx2.NextName=ScrollBoxEx3
  ScrollBoxEx3.PriorName=ScrollBoxEx2


NextSetFocus

  リファレンス
  TScrollBoxEx.NextSetFocus
  TScrollBoxEx

  NextSetFocusメソッドはNextNameプロパティに定義されたコンポーネントにフォーカスを移します。

  procedure NextSetFocus;

  説明
  NextSetFocusメソッドを呼び出すとNextNameプロパティに定義されたコンポーネントにフォーカスを移します。
  NextNameプロパティに定義されたコンポーネントの上位コンポーネントがTabSheetコンポーネントでさらに
  その上位コンポーネントがPageControlコンポーネントの場合、フォーカスを移す前に対応するページに切替えます。
  なお、NextNameプロパティに定義されたコンポーネントがScrollBoxExコンポーネントだった場合
  FirstSetFocusメソッドが動作します。

  使用方法および例


Create

  リファレンス
  TScrollBoxEx.Create
  TScrollBoxEx

  Create メソッドは，新しい TScrollBoxEx オブジェクトを作成および初期化します。

  constructor Create(AOwner: TComponent);

  説明
  Create メソッドを呼び出すと，新しいScrollBoxEx オブジェクトを作成および初期化できます。
  AOwner はスクロールボックスの解放を処理するコンポーネント（通常はフォーム）です。


Destroy

  リファレンス
  TScrollBoxEx.Destroy
  TScrollBoxEx

  Destroy メソッドは，メモリから TScrollBoxEx オブジェクトを削除します。

  destructor Destroy; override;

  説明
  Destroy メソッドを呼び出さないでください。かわりに，Free メソッドを呼び出してください。ScrollBoxEX オブジェクトが
  nil でない場合，Free メソッドは Destroy メソッドを呼び出します。


Refresh

  リファレンス
  TScrollBoxEx.Refresh
  TScrollBoxEx

  Refresh メソッドは，画面上にコントロールを再描画します。

  procedure Refresh;

  説明
  Refresh メソッドを呼び出さないと，表示明細部分は再描画されません。


Create

  リファレンス
  TTextMarge.Create
  TTextMarge

  Createメソッドは,TTextMargeのインスタンスを作成します。

  constructor Create( AOwner: TComponent ); override;

  説明
  Create メソッドを呼び出すと，実行時に TTextMargeのインスタンスを作成できます。
  設計時にフォーム上に配置された文字列グリッドの場合，Create メソッドは自動的に呼び出されます。
  AOwner パラメータはグリッドのオーナーになる別のコンポーネントで，一般的にはフォームです。
  オーナーは，グリッドの解放を担当します。


Destroy

  リファレンス
  TTextMarge.Destroy
  TTextMarge

  Destroyメソッドは,TTextMargeのインスタンスを破棄します。

  destructor Destroy; override;

  説明
  アプリケーションで直接 Destroy メソッドを呼び出さないでください。
  かわりに，Free メソッドを呼び出します。Free メソッドは，
  文字列グリッドが nil でないことを確認してからのみ Destroy メソッドを呼び出します。
  Destroy メソッドは，文字列とその関連付けられたオブジェクトの配列を
  管理するために使うヘルパーオブジェクトを解放します。


  社内コンポーネント

  シーエス作成コンポーネント　Copyright(C)シーエス


TScrollBoxEx

  リファレンス
  TScrollBoxEx
  継承　　プロパティ　　メソッド　　イベント　　貼り付け可能コンポーネント

  TScrollBoxEx は，ウィンドウ内のスクロール領域（スクロールボックス）を作成し
  その内部のコンポーネント間をEnterや矢印などでの移動を可能にした業務向けコンポーネントです。

  説明
  TScrollBoxExコンポーネントは大きく分けて２通りの使い方ができます。

  １つはパネル代わりにフォームに貼り付け、その上に各種コンポーネントを貼り付けて
  Enterや矢印などで移動するもの。

  もう１つは複数行入力用に各種コンポーネントのダミー表示をさせて
  コンポーネント間および行間をEnterや矢印などで移動するもの。

  使用例


TNumEdit

  リファレンス
  TNumEdit
  継承　　プロパティ　　メソッド　　イベント

  TNumEditは，数値入力に限定した 1 行編集コントロールです。

  説明
  TNumEdit を使うと，数値入力に限定した 1 行編集コントロールをフォーム上に配置できます。
  編集コントロールを使うと，入力されたテキストや表示しているテキストを取り出すことができます。

  使用例


TMCCBoxEx

  リファレンス
  TMCCBoxEx
  継承　　プロパティ　　メソッド　　イベント 例

  TMCCBoxExは，ドロップダウン時に複数カラム表示を可能にしたコンボボックスコントロールです。

  説明
  TMCCBoxEx を使うと，ドロップダウン時に複数カラム表示を可能にしたコントロールをフォーム上に配置できます。

  使用例

  上段は、コンボボックスで選択した１列目の内容が編集テキストに設定されます。
  中断は、コンボボックスで選択した行№（０～）が編集テキストに設定されます。
  下段は、コンボボックスで選択した２列目の内容は表示テキストに設定されます。


TCBColumn

  リファレンス
  TCBColumn
  継承　　プロパティ　　メソッド　　イベント 例

  TCBColumn は TMCCBoxExのカラム情報をカプセル化します。


TEditGrid

  リファレンス
  TEditGrid
  継承　プロパティ　メソッド　イベント

  TEditGridは,固定領域やEnter移動を可能にしたグリッドコンポーネントです。

  説明
  TEditGridコンポーネントは,幅、色、左右の揃え、上下の揃え、文字列編集
  Enterでの移動等を設定できます。

  使用例


TEGColumn

  リファレンス
  TEGColumn
  継承　プロパティ　メソッド　イベント

  TEGColumnは,TEditGridコンポーネントの列情報です。

  説明
  TEGColumnコンポーネントは,TEditGridコンポーネントの各列(0は１番目の列・・・）の
  列情報を指します。


TTextMarge

  リファレンス
  TTextMarge
  継承　プロパティ　メソッド　イベント

  TTextMargeは,文字列をつなげるコンポーネントです。

  説明
  TTextMargeコンポーネントは,２つのNumEditまたはEditコンポーネントの文字列をつなげます。

  使用例

  ２つのNumEditコンポーネント（３桁と７桁）がTextMargeコンポーネントに設定してあります。
  「→」ボタンで隠れているTextMargeコンポーネントからEditコンポーネントに
  「←」ボタンで隠れているTextMargeコンポーネントにEditコンポーネントから文字をセットしています。


TKanaEdit

  リファレンス
  TKanaEdit
  継承　プロパティ　メソッド　イベント

  TKanaEditは,IMEかな変換のかな文字を取得するコンポーネントです。

  説明
  TKanaEditコンポーネントは,Editコンポーネントに入力されたIMEかな変換時のかな文字を取得します。
  尚、かな変換をせずに直接セットされた文字列の修正については、独自ロヂックにより、修正されます。
  ので、本来のかなとは違うようになってしまうことがあります。

  使用例


TCalButton

  リファレンス
  TCalButton
  継承　プロパティ　メソッド　イベント

  TCalButtonは,カレンダーを表示させるスピードボタンコンポーネントです。

  説明
  TCalButtonコンポーネントは,Editコンポーネントの内容と
  MonthCalendarコンポーネントをリンクさせるものです。

  使用例


TCSPrint

  リファレンス
  TCSPrint
  継承　プロパティ　メソッド　イベント

  TCSPrintは,指定されたフォントのポイントで行、列指定できる印刷用コンポーネントです。

  説明
  TCSPrintコンポーネントは,TextPreviewコンポーネントを使用し
  用紙を意識せずに印刷できるものです。

  使用例